Problem using checkinstall for G2 svn
dv_mlist at verizon.net
Thu Jun 15 09:43:09 EDT 2006
On Wed, 2006-06-14 at 23:09 -0700, Thomas Bushnell BSG wrote:
> digger vermont <dv_mlist at verizon.net> writes:
> > Unfortunately not that I can see in Ubuntu, and Debian's gnucash
> > requires installing a good half dozen more Debian pkgs to fill
> > dependencies. If there are Unbutu packages floating around they're most
> > likely not for powerpc. Though I must say I haven't looked.
> You make it sound like those dependencies are somehow unnecessary. If
> they are actually unnecessary, then please report the bug!
> If they are not necessary, then what exactly is the problem with
> describing them?
Sorry, I didn't state the issue properly. The distribution/release I'm
using is Ubuntu Dapper. Though based on Debian there are differences in
the way Ubuntu names some packages. Also it looks like some packages
use a different versioning scheme. Some of the pkgs required by
Debian's Gnucash 2 are these.
For years I had been using Debian unstable and then started mixing in
Ubuntu packages that were missing from Debian or newer. It just got to
be too messy so I decided on just Ubuntu (I like Debian, a tough
decision). I'd rather not get drift back into that situation.
This is what I get from dpkg trying to install Debian's gnucash:
Selecting previously deselected package gnucash-common.
(Reading database ... 148585 files and directories currently installed.)
Unpacking gnucash-common (from gnucash-common_1.9.7-1_all.deb) ...
Selecting previously deselected package gnucash.
Unpacking gnucash (from gnucash_1.9.7-1_powerpc.deb) ...
Setting up gnucash-common (1.9.7-1) ...
dpkg: dependency problems prevent configuration of gnucash:
gnucash depends on libdbus-1-2 (>= 0.61); however:
Version of libdbus-1-2 on system is 0.60-6ubuntu8.
gnucash depends on libfreetype6 (>= 2.2); however:
Version of libfreetype6 on system is 2.1.10-1ubuntu2.1.
gnucash depends on libgnutls13 (>= 1.3.5); however:
Package libgnutls13 is not installed.
gnucash depends on libgpg-error0 (>= 1.2); however:
Version of libgpg-error0 on system is 1.1-4.
gnucash depends on libgsf-1-114 (>= 1.14.1); however:
Package libgsf-1-114 is not installed.
gnucash depends on libgsf-gnome-1-114 (>= 1.14.1); however:
Package libgsf-gnome-1-114 is not installed.
gnucash depends on libpango1.0-0 (>= 1.12.3); however:
Version of libpango1.0-0 on system is 1.12.2-0ubuntu3.
gnucash depends on libpopt0 (>= 1.10); however:
Version of libpopt0 on system is 1.7-5.
dpkg: error processing gnucash (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
More information about the gnucash-devel