gnucash gnome2-merge-10 at 10224,: Multiple changes pushed

John Ralls jralls at code.gnucash.org
Mon Mar 31 00:44:06 EDT 2014


        at  https://github.com/Gnucash/gnucash/tree/3d01896a780d5cb4b04fb2d3965ef77a56b460a5 (tag)
   tagging  3471012f0aa4b7d0774cfd3f6f49528b6ae9adc4 (commit)
  replaces  pre-gh-deprecate at 9948,
 tagged by  John Ralls
        on  Sat Aug 21 16:34:18 2004 +0000


Add option to advanced portfolio to include $0 splits (#143772).

Christian Stimming (4):
      (gnc_imap_add_account_bayes): Skip the case when a token is the empty string.
      For gcc3.4.x, add -Wdeclaration-after-statement warning switch.
      Add saving of reports.
      Add toolbar element for saving the current report.

David Hampton (2):
      Needs to include config.h.
      Added quote sources for Indian Mutual Funds.

Derek Atkins (32):
      automake-1.8.x is more pedantic about m4 quoting.
      Guile-1.6 doesn't allow string->symbol on a symbol (bug #131201).
      Vasil's patch to add "export" option to txn report.
      A few more QOF_QUERY_PARAM_GUID -> QOF_PARAM_GUID conversions.
      Fix memory corruption: add book_closing and use it.
      Auto-load a new "saved reports" config file.
      Add information about using cvs to create a patch.
      David Montenegro's Balance Sheet + Equity Statement patch (#144243).
      Add another test for Linas to fix
      Better "carry" flag to not overrun a signed 64-bit int (#114980).
      Fix a bunch of GUILE_WARN_DEPRECATED warnings.
      fix a deprecated guile function (use re-export)
      print out more info when trying to print/parse numerics.  There's
      Add another test to test-numeric to show a division overflow.
      Apply David Reiser's patch for Quicken(tm) cheques with stub.
      Add TD Efunds (#145297).
      get test-query to fail consistently.
      Get test-lots to die consistently.
      Improved checks for scanf %lld and %qd as per gc-devel mail.
      Make the bug#147025 failure reproducible.
      David Montenegro's patch for trial-balance (bug #144265).
      Forgot to add trial-balance.scm.
      David Montenegro's General Ledger patch (bug #155268).
      David Montenegro's patch to fix the pnl (income statement) #105330.
      David Montenegro's General Journal (bug #109738).
      Priit Laes' patch for C90 compliance.
      Make the gnucash desktop HIG compliant (#145545).
      David's patch to handle merchandising businesses (#150008).
      Check for newer gtkhtml first (#84707).
      Neil Williams's "QOF create: functionality added" patch.
      Perry Smith's Null Account patch.
      Add option to advanced portfolio to include $0 splits (#143772).

Linas Vepstas (164):
      Changes to get rid of most of the remaining usages of deprecated
      bug fix, book getter should have been returning book
      -- Rename QOF_QUERY_PARAM_XX to QOF_PARAM_XX
      whitespace fixes (convert tabs to spaces)
      partial fix for http://bugzilla.gnome.org/show_bug.cgi?id=139677
      update documentation
      whoops
      Do not try to compute cap gains if cap gains not possible.
      partial fix for the failure of the test-lots test case:
      -- make the gnc-numeric error codes be a typdef enum
      start of quick-n-dirty 128-bit math lib
      -- check for overflow during numeric multiply
      add 128-bit division & remainder support.
      add debugging print statements
      add fflush to make output appear sooner
      add a note about how to do the FIFO policy
      IMPORTANT Patch for performance; please test and port to g2 branch.
      Please port these changes to 1.8.x and g2 branches.
      remove deprecated has table routines
      add finalizers for the user-data hooks.  The finalizer is called when the
      Add documentation
      add documentation
      Add shared quick-fill for the register account-transfer pull-down combo
      fix core dump bug introduced by earlier last-minute changes.
      add doxygen documentation markup.
      fix the quickfill docos
      add a utility routine, do some minor performance tuning.
      fix horrid indentation (someone used tabs inconsistently)
      add more notes
      new, account-name quickfill utility
      source code for account quick-fill utility
      add account-cuickfill to the makefile,
      Minor documentation cleanup
      move the account-name quickfill code to the utilities directory, where
      Changes to use shared quick-fill for teh account transfer combo box.
      convert tabs to spaces (my tab stops aren't set to 8, so tabs wreck indentation)
      fix comments
      restore copyrights that had been previously removed.
      remove xaccGUIDType insanity in this dialog
      Add entity type to HTML reports.  Remove xaccGUIDType usage.
      remove borken xaccGUIDType usage.  The old code probably used to crash
      fix broken xaccGUIDType usage
      Remove the borken xaccGUIDType
      There should be two distinct entry lists, one holding incomes, one expenses
      patch to crash reported in comment 20,
      Fix typo
      little tweak to attempt to avoid overflow errors
      tweak to attempt to minimize numeric overflows
      whitespace, documentation tweaks
      improve doco's. Bump version number, which we should have done before.
      add version-compare routine
      whitspace fixes;
      add version-comarison hooks,
      rename 'new' to 'create' to avoid reserved word collision with C++
      initial checkin of core generic object ampping routine to CVS repository
      merge changes from the backend-work-1 branch.
      minor cleanup/restructure of how backends are located and loaded.
      move the file-path utilities out of qofsession.
      Remove the file-path utilities from qofsession.c and move them into
      add version param
      -- add loader for the dwi backend
      sync with qof sources
      add a parameter for-each function per request from Niel Williams
      add a foreach function to itereate over all registered classes.
      initial checkin -- automated numeric test
      add random-addition tests
      add more equivalence checks
      add more equality tests
      tweak the equality tests to avoid aliasing effects for large-number compares.
      expanded equality checks, begine multiply checks
      add divide tests, fix equality test
      work on the rounding tests
      more tests for the lcd
      tweak division
      add double-precision tests,
      add random division checks
      Pull dereks carry aptch into the division routines too
      rename carry flag to the 'isbig' flag;
      remove 32-bit limits that show up in division calculations
      -- fix the least-common-denominator algorithm
      -- finish work on add128
      fix the test case; it really is an overflow on division,
      add clarifying documentation
      partially completedd merger of texinfo documentation into teh header
      deprecate the gnc_numeric documentation
      finish folding in the now-obsolete texinfo documentation
      initial checkin of 18-bit integer math lib
      strip out the 128-bit math to its own stand-alone file
      add qofmath128.c -- for now, treat it as an inlinable header file, for now.
      changes to make doxygen documentation build
      tweaks to make the doxygen docs build correctly
      make random-numeric code more human-readable
      Audit use of gnc_numeric rounding and denom specification.
      Audit use of gnc_numeric functions
      add a shift-right (divide by two) function
      whoops, mised a flag
      add some debug statements,
      bug-fix for how large-number division is done
      128-bit division algorithm was badly broken,
      remove debug printf's move reduce routine out of 128-bit math lib
      add new/improved rounding/overflow test
      final form of test case
      bug fix -- the RND_NEVER flag was being ignored
      check for overflows in the remainder calculations ...
      adding a negative number to zero flips its sign! Oops!!
      add more tests involving negative quantities
      bug-fix -- adding negative num to zero used to give a positive result.
      -- improve debug printing messages.
      re-order math to make overflow less likely
      make the debug print statements more informational
      Last of the Mohicans
      fix what I beleive is the last of the overflow bugs.
      test driver tweaks
      That's not all, there's even more!
      tweak yet another possible overflow path
      remove commented out cruddy code
      re-order the way that random data is created,
      bugfix: failed to update list of frames correctly when the
      -- do not add voided transsactions to lots.
      -- reject voided transactions in cap-gains caluclations;
      change fifo/lifo policy to not serve up splits with a zero amount
      whitespace fixes
      style tweaks
      ignore test case binaries
      add function to compare (order) two numbers
      fix yet another intermediate-math overflow bug.
      improved diagnostic messages
      fix minor memory leak, the numeric_to-string returnes alloced memory
      fix null-pointer deref that results in core dump.
      fix really trite memory leak
      remove really dorky memory leak during debug printing
      the error log wasn't being initialized
      replace the algo in xaccTransGetImbalance() with a higher-performance version
      cleanup debug printing
      improve debug printing
      clean up test generator to produce self-consistent data.
      add to-do notes
      handle yet another overflow case in numeric multiplication.
      shuffle big blocks of code around; no actual changes to function
      add check -- cap gains not possible is value and amount are in the same
      improve debug printing
      add code to create intentionally borked transactions
      add code to make sure that split amount and value are valid numbers.
      fix test case failure by re-ordering block of code that checks for LCD
      add the failing test-query test as a special case
      re-order division so as to handle the failure of a special case
      port over to new typenames.
      add check for null pointer
      style tweak
      get rid of the srand
      tweak messages
      too many price-dbs are being created ... causing tests to fail
      sync overview notes with German wiki
      sync with German Wiki (I'm copying the description I wrote there to here).
      copy and edit transaction overview from the texinfo documentation
      edit/corect old and incorrect statements about how transactions work.
      Tweaks - Derek, can you upgrade the version of doxygen on cvs.gnucash.org?
      add overview, cut and pasted from recently revised texinfo docs.
      small gnuplot script to graph the total number of lines of code in
      raw data for number of lines of code in gnucash.
      Apply patch from Neil Williams <linux at codehelp.co.uk>
      Apply patch from Neil Williams <linux at codehelp.co.uk>
      documentation cleanup; merge from qof sources
      add some to-do notes for later





More information about the gnucash-patches mailing list