[Gnucash-changes] r12184 - gnucash/trunk - raname internal fmin() to gogi_fmin().

Derek Atkins warlord at cvs.gnucash.org
Tue Dec 27 10:41:08 EST 2005


Author: warlord
Date: 2005-12-27 10:41:07 -0500 (Tue, 27 Dec 2005)
New Revision: 12184
Trac: http://svn.gnucash.org/trac/changeset/12184

Modified:
   gnucash/trunk/ChangeLog
   gnucash/trunk/lib/goffice-0.0.4/plugins/plot_radar/gog-radar.c
Log:
raname internal fmin() to gogi_fmin().

	* lib/goffice-0.0.4/plugins/plot_radar/gog-radar.c:
	  rename 'fmin()' to 'gogi_fmin()' to prevent double
	  declaration on MacOS.  It's an internal (static) function
	  so we can safely rename the function.



Modified: gnucash/trunk/ChangeLog
===================================================================
--- gnucash/trunk/ChangeLog	2005-12-27 02:17:49 UTC (rev 12183)
+++ gnucash/trunk/ChangeLog	2005-12-27 15:41:07 UTC (rev 12184)
@@ -1,3 +1,10 @@
+2005-12-27  Derek Atkins  <derek at ihtfp.com>
+
+	* lib/goffice-0.0.4/plugins/plot_radar/gog-radar.c:
+	  rename 'fmin()' to 'gogi_fmin()' to prevent double
+	  declaration on MacOS.  It's an internal (static) function
+	  so we can safely rename the function.
+
 2005-12-26  David Hampton  <hampton at employees.org>
 
 	* src/import-export/hbci/glade/hbciprefs.glade: Remember value of

Modified: gnucash/trunk/lib/goffice-0.0.4/plugins/plot_radar/gog-radar.c
===================================================================
--- gnucash/trunk/lib/goffice-0.0.4/plugins/plot_radar/gog-radar.c	2005-12-27 02:17:49 UTC (rev 12183)
+++ gnucash/trunk/lib/goffice-0.0.4/plugins/plot_radar/gog-radar.c	2005-12-27 15:41:07 UTC (rev 12184)
@@ -387,8 +387,7 @@
 typedef GogPlotViewClass	GogRTViewClass;
 
 static double
-//double
-fmin (double a, double b)
+gogi_fmin (double a, double b)
 {
 	return (a < b) ? a : b;
 }
@@ -519,7 +518,7 @@
 			      GogObject const *cur_selection,
 			      GogObject **obj, char **name)
 {
-	double radius = fmin (view->allocation.h, view->allocation.w)/2.0;
+	double radius = gogi_fmin (view->allocation.h, view->allocation.w)/2.0;
 
 	x -= view->allocation.x + view->allocation.w/2.;
 	y -= view->allocation.y + view->allocation.h/2.;



More information about the gnucash-changes mailing list