r20716 - gnucash/trunk/src/gnome-utils - Rename gtk_quartz_shutdown, gtk_quartz_should_quit, and gtk_quartz_set_menu to gnc_quartz_... for better naming consistency and conformance to GObject naming standards.

John Ralls jralls at code.gnucash.org
Sat May 28 17:52:54 EDT 2011


Author: jralls
Date: 2011-05-28 17:52:54 -0400 (Sat, 28 May 2011)
New Revision: 20716
Trac: http://svn.gnucash.org/trac/changeset/20716

Modified:
   gnucash/trunk/src/gnome-utils/gnc-main-window.c
Log:
Rename gtk_quartz_shutdown, gtk_quartz_should_quit, and gtk_quartz_set_menu to gnc_quartz_...  for better naming consistency and conformance to GObject naming standards.

Modified: gnucash/trunk/src/gnome-utils/gnc-main-window.c
===================================================================
--- gnucash/trunk/src/gnome-utils/gnc-main-window.c	2011-05-28 20:04:38 UTC (rev 20715)
+++ gnucash/trunk/src/gnome-utils/gnc-main-window.c	2011-05-28 21:52:54 UTC (rev 20716)
@@ -151,9 +151,9 @@
 static gboolean gnc_main_window_popup_menu_cb (GtkWidget *widget, GncPluginPage *page);
 
 #ifdef MAC_INTEGRATION
-static void gtk_quartz_shutdown(GtkOSXApplication *theApp, gpointer data);
-static gboolean gtk_quartz_should_quit(GtkOSXApplication *theApp, GncMainWindow *window);
-static void gtk_quartz_set_menu(GncMainWindow* window);
+static void gnc_quartz_shutdown(GtkOSXApplication *theApp, gpointer data);
+static gboolean gnc_quartz_should_quit(GtkOSXApplication *theApp, GncMainWindow *window);
+static void gnc_quartz_set_menu(GncMainWindow* window);
 #endif
 
 /** The instance private data structure for an embedded window
@@ -3409,7 +3409,7 @@
  * loop.
  */
 static void
-gtk_quartz_shutdown (GtkOSXApplication *theApp, gpointer data)
+gnc_quartz_shutdown (GtkOSXApplication *theApp, gpointer data)
 {
 /* Do Nothing. It's too late. */
 }
@@ -3421,7 +3421,7 @@
  * opportunity to shut down.
  */
 static gboolean
-gtk_quartz_should_quit (GtkOSXApplication *theApp, GncMainWindow *window)
+gnc_quartz_should_quit (GtkOSXApplication *theApp, GncMainWindow *window)
 {
     QofSession *session;
     gboolean needs_save, do_shutdown;
@@ -3440,7 +3440,7 @@
 }
 
 static void
-gtk_quartz_set_menu(GncMainWindow* window)
+gnc_quartz_set_menu(GncMainWindow* window)
 {
     GtkOSXApplicationMenuGroup *group;
     GtkOSXApplication *theApp = g_object_new(GTK_TYPE_OSX_APPLICATION, NULL);
@@ -4102,12 +4102,12 @@
     {
         gtk_widget_show(GTK_WIDGET(window_iter->data));
 #ifdef MAC_INTEGRATION
-        gtk_quartz_set_menu(window_iter->data);
+        gnc_quartz_set_menu(window_iter->data);
 #endif
     }
 #ifdef MAC_INTEGRATION
     g_signal_connect(theApp, "NSApplicationWillTerminate",
-                     G_CALLBACK(gtk_quartz_shutdown), NULL);
+                     G_CALLBACK(gnc_quartz_shutdown), NULL);
     gtk_osxapplication_ready(theApp);
 #endif
 }



More information about the gnucash-changes mailing list