gnucash: New annotated tag '3.903'

John Ralls jralls at code.gnucash.org
Mon Jun 1 13:57:59 EDT 2020


        at  https://github.com/Gnucash/gnucash/tree/80f3c469dba47c24e56ccf97d00f4aa97913a99d (tag)
   tagging  ff8075569e53f4a62f54ed6300ee8815c584fc79 (commit)
  replaces  3.902
 tagged by  John Ralls
        on  Mon Jun 1 09:35:52 2020 -0700


Tag Release 3.903

Christian Gruber (8):
      Add mock classes for book, account, transaction and split
      Initial test setup
      Add test-import-backend to CMakeLists.txt
      Add mock classes for prefs and qofquery
      Add further required mock functions
      Add first test for creation of transaction info
      Add second fixture for testing bayesian import matching
      Add first test using fixture ImportBackendBayesTest

Christopher Lam (59):
      [gnc-lot.c] speed up gncInvoiceGetInvoiceFromLot by caching invoice
      [income-gst-statement] add UK VAT and AU GST rules
      [test-income-gst] add uk-vat and au-bas tests
      Merge chris 'UK-VAT and AU-GST' branch
      Bug 797707 - CSV Transaction Export: custom dates should be insensitive by default
      {new-}aging: swap guids, hook to new-aging
      {new-}owner-report: swap guids, hook to new-owner-report
      balance-sheet/income-statement{-pnl}: swap guids
      [reports] use new module names
      [balsheet-pnl] multichoice option uses symbol instead of #f
      Merge branch 'maint'
      [Account.cpp] more xaccAccountTypeGetFundamental types
      [test-stress-options] fix combinatorics testing
      Bug 797659 - Liabilities in budget report no longer calculate correctly
      [eguile-gnc] don't catch errors in eguile-gnc
      [balsheet-eg] use "foreign" css class correctly
      [eguile-utilities] deprecate single-use function
      [balsheet-eg] reindent process-acc-list-r
      [balsheet-eg] don't use safe-cadr and safe-cdr
      [c-interface] compact code, use (ice-9 match)
      Merge branch 'maint'
      [trep-engine] "Transaction Filter is case insensitive"
      Merge branch 'maint-trep-case-insensitive' PR #719
      Bug 797743 - Monetary amounts are occasionally rendered in fractions
      [gnc-ui-util] add gnc_price_print_info
      [html-style-info] export gnc:default-price-renderer
      [html-utilities] use new price renderer for exchange-rate table
      [balsheet-pnl] use new price renderer
      [balsheet-eg.eguile] use new price renderer
      [advanced-portfolio] use new price renderer
      [trep-engine] use new price renderer
      [register] [bugfix] use new price renderer
      Merge branch 'maint-797743' #720 price renderers
      [register] show number columns right-aligned
      Bug 796932 - Invoices order when assigning payments
      [register] price shown in transaction currency rather than account's parent currency
      Merge branch 'master-796932'
      [register] display $0.00 for zero-value splits
      Merge branch 'speedup-aging' #638
      [taxinvoice.eguile] simplify
      [taxinvoice] remove dead code, simplify
      [receipt.eguile] simplify
      [html-chart] add z-index:999 to anchor
      Bug 797761 - Customer report beta: opening balance tax column shows garbage string
      [new-aging] speed up split->owner
      [dashboard] enable Dashboard report properly
      Bug 797770 - Reconciliation report does not consider credit transactions
      typo fix
      Merge branch 'master-guid-dance' #706
      deprecate old reports
      Bugfix new reports
      Upgrade split->owner to gnc:split->owner
      Use gnc:split->owner instead of gnc:owner-from-split
      [cli-reports] run reports from cli
      instead of saved-reports only, dump in-menu? reports alphabetically
      Check all known report templates instead of just custom reports.
      cli-reports: if run-report matches multiple, offer choices
      [gnucash-commands] fprintf instead of g_warning
      [gnucash-commands] don't force open a locked datafile

Frank H. Ellenberger (12):
      Add a tip about announcements and other mailing lists
      I18N: Hotfix for bug 797725
      I18N: Msgmerge recent changes
      Use more precise strings in gnc-split-reg.c
      I18N: Fix several issuse with 'Help not found' strings
      I18N: fix translator comments in window-reconcile.c
      HIG, I18N: Improve Budget menu entries
      HIG, I18N: Improve Budget menu entries and tooltips
      L12N:de Ammend last commit about Python messages
      Merge PR #727
      Update description of gnc_gnome_help and gnc_launch_assoc
      Merge branch 'maint'

Geert Janssens (32):
      Display report zoom factor with one decimal space.
      Bug 797717 - Summary bar changes height when opening a menu or scrolling over an option
      Merge branch 'maint'
      Fix crash in case filter is less than 4 parameters
      add-price-quotes doesn't use modules, so don't load them
      Drop unrelated source file from POTFILES.in
      Add mock sources and import-export test to dist
      Add files omitted in previous commit
      Fix build depencency hiccup
      Rename main source file from gnucash-bin.c to gnucash.c
      Build gnucash main file as C++
      Introduce new executable 'gnucash-cli'
      Extract common setup bits from gnucash and gnucash-cli into a separate class Gnucash::Base
      Further cleanup in gnucash and gnucash-cli
      Switch to using boost::locale::format and iostream for printing messages
      Reformat Objective C code to work around a KDevelop bug.
      Rename Gnucash::Base to Gnucash::CoreApp
      Only offer gtk options for gnucash, not for gnucash-cli
      Port command line option handling to boost::program_options
      Pass argc and argv by value instead of by reference
      Make options that don't take arguments bool_switch type
      Catch unrecognized command line options
      Return from main instead of exiting
      Factor out common quotes retrieval code into a new file gnucash-commands.cpp
      Rework gnucash startup code to be a Gnucash class member function
      Fix log initialization
      Use common input file parameter for gnucash-cli --add-price-quotes
      Move saved report loading to report initialization code
      Small tweaks that got left out by mistake
      C++ tweaks
      A few translation tweaks in gnucash and gnucash-cli
      Make gnucash-cli report errors to stderr by default.

John Ralls (91):
      Fix libgnc-app-utils.dylib install_name_dir.
      Respect the environment LD_LIBRARY_PATH for loading Scheme modules and tests.
      Fix transaction post_date being set to midnight local.
      Shut up a cmake policy warning.
      No need for a separate decl and def of a static inline function.
      Extract Function gnucash_sheet_set_entry_value.
      Relocate some static functions to avoid pre-declaring them.
      Fix test failure for timezones west of the prime meridian.
      Extract several functions for managing GtkEntry position and selection
      Extract function process_motion_keys.
      Extract function pass_to_entry_handler.
      Extract functions make_new_text, delete_text, insert_text, normalize_bounds
      Use the GtkEntry's GtkIMContext instead of creating one for the sheet.
      Bug 797052 - Autofill Selection is Corrupted After Clicking Description
      Merge John Ralls's 'ime-fix' into master.
      Fix build  on Ubuntu-18.04.
      Clean up some leftover noise from the ime-fix branch.
      Don't mutate the cached global account list store.
      Fix LIBDBI_DRIVERS_DIR generation.
      Merge branch 'maint'
      Decouple QofBook creation from QofSession.
      Remove duplicate decl.
      Don't ask to save a non-existant book.
      Move QofLogModule typedef to qoflog.h where it belongs.
      Make qof_log_set_file static.
      [QofLog] Replace hashtable with tree of vectors.
      Merge Jean Laroches '797737_match_previously_matched_trans' into maint.
      Fix undeclared std::find_if.
      Two more test directories needing G_LOG_DOMAIN defined.
      Reports dependency fixes.
      Fix clang error about type mismatch GtkWidget* != void* aka gpointer
      Don't use g_return_value_if_fail in qof_log_check.
      Fix wrong Boost library variable names.
      Fix incorrecly logging all possible messages regardless of log level.
      Use std::unique_ptr instead of std::shared_ptr.
      Bug 797748 - missing header "algorithm"
      Restore AQBanking to operation.
      Bug 797750 - SIGSEV in swig-engine.c
      Fix abort in qof_log_check.
      Remove actions on the control, shift, and alt keys.
      Fix delete ignores selection in register cells.
      Initialize the bounds variables in gnucash_sheet_insert_cb.
      Remove redundant use of gtk_accelerator_get_default_mod_mask().
      Ensure gnc_item_list's temp_store is NULL when list store is in use.
      combocell-gnome: Process deletes and inserts before performing matching.
      combocell_gnome: Block signals for all list deletes.
      combocell_gnome: Prevent starting off in type-ahead mode on entry
      Bug 797760 - Broken register split activity...
      Use correct type of 0 for char* return value.
      Connect to the popup's size-allocate signal only once.
      gnc_item_list_num_entries: Count the GtkListStore in use.
      Get rid of GncScrolledWindow.
      gnc_combo_cell: Remove the vertical scrollbar if the list store is small.
      Recalculate type-ahead search when deleting.
      Merge Christian Gruber's 'test_import_backend' into master.
      Merge Bob Fewell's 'gnc-edit-changes' into master.
      Delete unused function gnucashsh_sheet_get_text_cursor_position.
      Make static gnucash_sheet_cursor_get, used only internally.
      Exclude mock files from translation.
      Fix binreloc compile error with gcc.
      Move the Windows README files to gnucash-on-windows where they belong.
      Remove obsolete documentation files.
      Place the cursor after the preedit.
      gnucash-item-edit.c: Small whitespace fixup.
      Fix printf arg mismatch, windows build failure.
      Merge Jean Laroche's '797220_delete_account_wrong_currency' into master.
      Plugin-page-account: Extract function commodity_mismatch_dialog.
      gnc-plugin-page-account-tree.c: delete_account_next fix leaks and whitespace.
      Delete Account: Modify strings for single subaccount.
      Delete Account: Abstract the disposition adopters into a struct.
      Extract function account_delete_dialog.
      Delete account: Rename and reflow helper functions.
      Delete Account: Short circuit checks if no transactions or subaccounts.
      Delete Account: Use subaccount commodity for subaccount splits.
      python-gettext-localize: Additional POTFILES.in changes.
      Merge Christoph Holterman's python-gettext-localize into master.
      MacOS Build Fixes
      Make run-report member variable names consistent.
      gnucash-cli: Actually run the report.
      Convert args passed to run reports to const std::string&.
      gi18n.h, binreloc.h, and gnc-engine.h have C linkage.
      Extract set_win32_thread_locale() to a new C file gnucash-windows-locale.c
      Don't try to build gnucash-windows-locale.c on non-Windows OSes.
      Prevent libstdc++ copysign declaration error on Win32.
      Add gnucash-windows-locale.c to POTFILES.in
      New Ukrainian translation for 4.x from the translation project.
      Merge branch 'maint'
      Put command logging back to logging.
      Provide an error message for ERR_BACKEND_LOCKED.
      Release 3.903.
      Include gnucash-windows-locale.c in the dist.

Mike Alexander (6):
      Add a newline to the GNC_DBD_DIR line in the environment file.
      Define log_module in gnc-sx-instance-model.c.
      Remove some globals by moving them into the struct passed to callbacks.
      Initially select the last account chosen in the account picker dialogs.
      CLean up the binreloc code a bit.  It is won't work pervectly, but it's better.
      Don't call gnc_path_get_localedir vefore binreloc is initialized.

Robert Fewell (67):
      Remove some Gtk version checks for CSS
      Remove some Gtk version checks in code
      Change occurrences of gdk_display_get_default
      Merge Jean Laroche's branch 'fix_seg_fault_in_matcher'  into maint
      Merge Chris Good's branch 'bug797648Rec-2', PR #713 into maint
      Merge Chris Good's branch 'bug797236RecMas', PR #707 into master
      Merge Chris Good's branch 'bug797688RecAddSubAcct', PR #709 into master
      Align the import matcher help button
      Change the Tax Table dialogue to be based on a GtkWindow
      Change layout of source file dialog-tax-tables.c
      Bug 797689 - Change the Bill Terms Table dialogue to be based on a
      No Selection on load for Bill Terms
      Change layout of source file dialog-billterms.c
      Correct parent widget for import new account dialog.
      Transaction matcher dialogue was not closing when changing book.
      Bug 797745 - Unable to change default report currency
      Test for a valid register state comment before trying
      Add option to save Layout for Business items
      Change state_section parameter for gnc_table_save_state
      Add enum SplitRegisterTypeGroup to group registers
      Add option to save Layout for Register items
      Remove the state key file comment for Account filter
      Remove the setting of a comment for registers
      Complete the move of saving register filter/sort to .gcm
      Enable the Options Checkbox label to be used to toggle
      Remove some spaces and tabs from dialog-options.c
      Change the Options Checkbox
      Reselect the transaction rows in import-main-matcher
      Bug 797754 - Account Register scrolling stops working
      Fix combocell when using action field
      Error for g_signal_handler_disconnect in trace file
      Move setting up of the sheet popup size-allocate callback
      Change the way the sheet popup treeview height is obtained.
      Remove extra vbox in gnc_item_edit.c
      Drop gnucash-scrolled-window.c in POTFILES.in as it has
      Bug 797768 - View Lots sorting numbers not right.
      Change the alignment of the numeric values in the lot viewer
      Set the expanding column in the lot viewer
      Set horizontal paned position in Lot viewer
      Fix the alignment of the Notes label in Transfer dialog
      Change the position the register pop up so it aligns better
      Merge Jean Laroche's branch 'add_multi_ofx_import_master' PR 697 to master
      Set the reconcile after close button in import-main-matcher
      Rename a couple of functions used in multiple OFX file import
      Add file name to dialog used in ofx import
      Delete Account: Short circuit checks if no transactions or subaccounts
      Rename the trans associate files
      Minor text changes to reflect associated file name changes
      Move the transaction association dialog to dialog-assoc.c/h
      Bug 797185 - Allow sorting on all Transaction Association columns
      Bug 797185 - Add Reload button for Transaction associations
      Allow the Transaction Association to be updated from list
      Add option to change associations when path head changes
      Change dialog-assoc functions to use ones from dialog-assoc-utils
      Change gnc_launch_assoc function
      Change the File dialogue for associations
      Add a new cell type for Transaction associations that
      Display glyphs for Transaction Associations
      Change register sheet associations tooltip to use
      Add KVP Association property to GncInvoice
      Replace tabs with spaces in gncInvoice.c/h
      Allow Associations to be added to invoices
      Add an Invoice section to dialog-utils for when the  path head changes
      Change Associations list dialog for Business
      Add a total entries label to the Association dialogue
      Bug 796531 - Display the Transaction Association link
      Add opening the transaction association from register sheet.

Thomas Schärli (2):
      L10N:de_CH: Ein weiterer Tippfehler im Kontenrahmen KMU
      L10N:de: "Für" klein in "Ergebnisrechnung für Periode" etc.

c-holtermann (17):
      implement gettext localization for python
      localize strings for python
      add translatable python files
      install gettext
      add test for gettext
      debug on travis
      further debugging
      further debugging
      remove debug stuff (temporarily)
      remove debug info
      remove global gettext import
      test info
      remove debug stuff
      locale is not needed anymore (debug)
      remove translation test
      update with recent gnucash.pot
      updates for python gettext

goodvibes2 (7):
      Bug 797388 - Add watch for ea subacct of the acct to be reconciled
      Bug 797236 - Reconciliation - Retain visibility of selected split.
      Reconcile window - Retain position in split list after deletion
      Fix 2 comment typos in gnucash/gnome/window-reconcile.c
      Revert "Use Doxygen format for function comment"
      Revert "Bug 797648 - Fix problem reconciling multiple splits in a transaction"
      Bug 797648 Redo - Reconciliation - Treat each split independently

jean (6):
      Bug 797220 - delete account allows move of all transactions to account having non-matching currency
      Split long function into two sub-functions. Prevent deleting accounts with more than 1 subaccount. Verify currency match for sub-account when it is to be moved or its transactions are to be moved
      Fix the crash that occurs when opening a new book when the transaction-matching dialog has been opened then closed.
      Refactor, breaking large function.
      Bug 797737 - Import matching can match an imported transaction to an existing, previously matched transaction
      Implement multiple-ofx import with reconcile





More information about the gnucash-changes mailing list