From jralls at code.gnucash.org Wed Aug 5 12:00:16 2026 From: jralls at code.gnucash.org (John Ralls) Date: Wed, 5 Aug 2026 12:00:16 -0400 (EDT) Subject: gnucash-docs stable: Multiple changes pushed Message-ID: <20260805160016.E99F78DCCB5@code.gnucash.org> Updated via https://github.com/Gnucash/gnucash-docs/commit/d1e03771 (commit) via https://github.com/Gnucash/gnucash-docs/commit/827f5d17 (commit) from https://github.com/Gnucash/gnucash-docs/commit/8ae8d1d4 (commit) commit d1e03771ac88e9427584718e6b0892f0522d5610 Merge: 8ae8d1d4 827f5d17 Author: John Ralls Date: Wed Aug 5 08:58:34 2026 -0700 Merge P. G. Faller's 'quotes' into stable. commit 827f5d172342d9b0488fd5770b03e88fb4a2c4bc Author: Peter Faller Date: Wed Aug 5 08:54:03 2026 +0200 Changed 'courses' to 'quotes' From the context, it looks like 'quotes' is the right word. diff --git a/C/manual/ch_Account-Actions.docbook b/C/manual/ch_Account-Actions.docbook index 0d867dce..ce30c411 100644 --- a/C/manual/ch_Account-Actions.docbook +++ b/C/manual/ch_Account-Actions.docbook @@ -283,7 +283,7 @@ - &app; uses an external tool to retrieve online courses. This tool is a Perl module called &app-fq; + &app; uses an external tool to retrieve online quotes. This tool is a Perl module called &app-fq; and must be installed independently of &app; on your computer. Summary of changes: C/manual/ch_Account-Actions.docbook | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) From clam at code.gnucash.org Thu Aug 6 10:38:16 2026 From: clam at code.gnucash.org (Christopher Lam) Date: Thu, 6 Aug 2026 10:38:16 -0400 (EDT) Subject: gnucash stable: [Transaction.cpp] null check before accessing struct member Message-ID: <20260806143816.CC02D8DCCB4@code.gnucash.org> Updated via https://github.com/Gnucash/gnucash/commit/a4f69f44 (commit) from https://github.com/Gnucash/gnucash/commit/c935c2fb (commit) commit a4f69f44a79d467a98ed92f56ad2738f3174f2a6 Author: Christopher Lam Date: Thu Aug 6 22:27:34 2026 +0800 [Transaction.cpp] null check before accessing struct member diff --git a/libgnucash/engine/Transaction.cpp b/libgnucash/engine/Transaction.cpp index 67e28e75cc..56d3c59dfa 100644 --- a/libgnucash/engine/Transaction.cpp +++ b/libgnucash/engine/Transaction.cpp @@ -1324,8 +1324,9 @@ split_set_new_value(Split* split, gnc_commodity *curr, gnc_commodity *old_curr, void xaccTransSetCurrency (Transaction *trans, gnc_commodity *curr) { - gnc_commodity *old_curr = trans->common_currency; if (!trans || !curr || trans->common_currency == curr) return; + + gnc_commodity *old_curr = trans->common_currency; xaccTransBeginEdit(trans); trans->common_currency = curr; Summary of changes: libgnucash/engine/Transaction.cpp | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) From jralls at code.gnucash.org Thu Aug 6 13:13:06 2026 From: jralls at code.gnucash.org (John Ralls) Date: Thu, 6 Aug 2026 13:13:06 -0400 (EDT) Subject: gnucash stable: Multiple changes pushed Message-ID: <20260806171306.5369E8DCCBB@code.gnucash.org> Updated via https://github.com/Gnucash/gnucash/commit/41167c22 (commit) via https://github.com/Gnucash/gnucash/commit/ac5932e2 (commit) from https://github.com/Gnucash/gnucash/commit/a4f69f44 (commit) commit 41167c22014a3653ffbd8cde08c6f751e1c7fb47 Merge: a4f69f44a7 ac5932e2ba Author: John Ralls Date: Thu Aug 6 10:09:40 2026 -0700 Merge PRG's 'chart-tooltip' into stable. commit ac5932e2ba72605e0aceeb3714fef5265af7d0ae Author: PRG-112 Date: Tue Aug 4 12:46:42 2026 +0200 Enhancement - making the tooltip more readable (https://bugs.gnucash.org/show_bug.cgi?id=799799) https://bugs.gnucash.org/show_bug.cgi?id=799799 A small change for making the tooltip more readable as it can get very messy with bigger data-sets. (see the screenshot) >> Screenshots based on: GC Sample Database: https://github.com/PRG-112/gnucash-sample-db-generator diff --git a/gnucash/report/html-chart.scm b/gnucash/report/html-chart.scm index 1fb1817c8b..541495c135 100644 --- a/gnucash/report/html-chart.scm +++ b/gnucash/report/html-chart.scm @@ -374,7 +374,7 @@ function tooltipLabel(tooltipItem,data) { var label = data.datasets[tooltipItem.datasetIndex].data[tooltipItem.index]; switch (typeof(label)) { case 'number': - return datasetLabel + ': ' + numformat(label); + return ' ' + datasetLabel + ' : ' + numformat(label); default: return ''; } Summary of changes: gnucash/report/html-chart.scm | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)