gnucash: New annotated tag '5.17'

John Ralls jralls at code.gnucash.org
Sat Sep 26 16:25:36 EDT 2026


        at  https://github.com/Gnucash/gnucash/tree/cd93b19fa5dc14a7c9bb6265269f06ecd625dc10 (tag)
   tagging  0e302675fff4bf6dccf62ba876c7d306b7152d0e (commit)
  replaces  5.16
 tagged by  John Ralls
        on  Sat Sep 26 12:58:23 2026 -0700


Release GnuCash 5.17

Alonso González Chaves (1):
      Translation update  by Alonso González Chaves <algonza at live.com> using Weblate

Arve Eriksson (1):
      Translation update  by Arve Eriksson <arve.eriksson at startmail.com> using Weblate

Bruce Schuck (1):
      Removed MorningstarUK and MorningstarCH

Ceaus (1):
      Translation update  by Ceaus <github at pohw.nl> using Weblate

Christian Wehling (1):
      HBCI is a subtype of FinTS, therefore some text passages have to be

Christopher Lam (33):
      [test-report-utilities.scm] add test at date boundaries
      [report-utilities.scm] convert account value accumulator to c++
      [investment-lots] use faster gnc-account-foreach-split-between-dates
      [report-utilities.scm] upgrade hash-ref! to report-utilities.scm
      [html-acct-table.scm] avoid gnc:account-get-trans-type-splits-interval
      [html-acct-table] bugfix last commit - scan accounts once
      [gnc-euro.cpp] store euro rates as GncNumeric
      [gnc-euro.cpp] use GncNumeric.convert() instead of gnc_numeric_convert
      [Transaction.cpp] null check before accessing struct member
      [dialog-bi-import.c] don't strcpy onto zero-length id
      [html-chart.scm] each chart must isolate its vars and helper fns
      Bug 799772 - Invoice layout: footer should span both columns and header tables should be easier to align/style
      [stylesheets/footer.scm] add markup "stylesheet-footer" to footer
      xaccSPrintAmount needs at least 64 bytes
      [gnc-gobject-utils.c] plug gobject_tracking leak
      [gnc-plugin-page-report.cpp] save initial_report instead of cur_report
      [assistant-stock-transaction] Jump to new stock transaction
      [gnome/test] fix test-assistant-stock-transaction linked dirs
      [import-parse.cpp] compile regex before trying to parse dates
      [import-export/test] add tests for gnc_import_parse_date|numeric
      [import-parse.h] #ifdef guards after #includes
      [Transaction.cpp] use g_list_sort to partition splits
      [reports] fix scheme indenting, and use scheme conventions
      [html-chart] centralize gnc:html-chart-set-tooltip-caretpadding!
      [html-chart] rename fn call to gnc:html-chart-set-tooltip-mode!
      [html-chart] apply preferences to gnc:html-chart object
      [html-chart] centralize gnc:html-chart-set-tooltip-caretpadding-from-prefs!
      [libgnucash/app-utils/test] test shouldn't include gnc-gnome-utils
      [engine.i] delegate gnc:html-string-sanitize to g_markup_escape_text
      [test-scm-utilities.scm] addendum last commit "quote" now sanitized
      [account.hpp] introduce gnc_account_foreach_split_between_dates
      [account.cpp] use gnc_account_foreach_split_between_dates
      [engine.i] use gnc_account_foreach_split_between_dates

Claude (2):
      [doclinkcell.c] plug GtkLabel leak in gnc_doclink_cell_set_use_glyphs
      [new-owner-report] Scope script to its table, use keyboard toggle

Giuseppe Foti (1):
      Translation update  by Giuseppe Foti <foti.giuseppe at gmail.com> using Weblate

Gwyn Ciesla (1):
      Replace removed Python 2 C API macros for SWIG 4.5.0 compatibility

Huang, Zhaoquan (3):
      Add context field in gnc-glossary.txt
      Format all glossary po files through rename-glossary.py
      Split context/category to msgctxt field in gnc-glossary.txt

John Ralls (44):
      Merge Sherlock's 'bug799753' into stable.
      Update to the latest translations from Weblate.
      Merge Copy String's 'aqbanking-noted-transactions' into stable.
      Merge Thomas Teixeira's 'bug799774' into stable.
      Merge Noah Noerr's 'readonly-skip-dbi-library-test' into stable.
      Merge Noah Noerr's 'fix-qofsession-end-releases-lock' into stable.
      CMakeLists.txt: Fix function-name typo.
      Update supported platforms in README.
      Merge Sherlock's 'stock-splits' into stable.
      Add build of Doxygen Docs to CI, upload to gnucash.github.io
      Clarify IBM hardware type that can compile GnuCash.
      Support both coverage and documentation
      Doxygen: Set header version to VCS version if building from VCS
      Bug 799791 - Unvoid is not available (Bug from the mailing lists)
      Document that transaction void-time invalid value is now INT64_MAX.
      Merge Sherlock's 'csv-split-order' into stable.
      Edit Exchange Rate: Improve the message and comment
      Merge PRG's 'chart-tooltip' into stable.
      Guile Bindings: Fix error in GncOptionDB::foreach_section wrapper
      Merge Jitka Plesnikova's 'swig-4.5' into stable.
      Merge Bruce Schuck's 'rm-morningstaruk' into stable.
      Merge the latest translations from WebLate.
      Deleted Glossary translation using Weblate (German (Switzerland))
      Merge PRG-112's 'cash-flow-account-list' into stable.
      Bug 799806 - Locale "C.UTF-8" crashes the Mortgage and Loan Repayment Assistant
      Merge Christian Wehling's 'HBCI' into stable
      Merge PRG-112's 'chart-tooltip-improvements' into stable.
      Mingw64: Use a manifest to force the codepage to UTF8
      mingw32: Force the C runtime to use the process's code page.
      mingw32: Use msvcrt's _wsetlocale in set_platform_ctype_to_acp.
      Merge latest translations from Weblate.
      msgmerge the 5.17 gnucash.pot to prepare for next release.
      Merge Huang Zhaoquan's 'bug-799803' into stable.
      Merge Roy Hansen's 'improve/natural-sort-id-columns' into stable.
      Qif Import: Fix segment order when parsing YDM dates.
      Bug 799813 - gnucash-cli issue for price updates using Postgressql back-end
      Merge Noah Noerr's 'python-pricesource-enum' into stable.
      Correct the summary and description for the chart-tooltip-position preference schema.
      Merge Noah Noerr's 'bug799796-price-example-getvalue' into stable.
      Merge Noah Noerr's 'python-guard-price-set-source-string' into stable.
      engine.i: Fix typo.
      Merge Chris Lam's 'acc-templated-split-iterator' into stable.
      Bug 797872 - Multiple check printing results in nothing sent to print queue after first check
      Release GnuCash 5.17

Kraksen (1):
      Translation update  by Kraksen <kraks at users.noreply.hosted.weblate.org> using Weblate

Miroslav Kure (1):
      Translation update  by Miroslav Kure <kurem at upcase.inf.upol.cz> using Weblate

Noah R (2):
      [engine] qof_session_end: release the lock via the session's backend
      [backend/dbi] skip the libdbi integrity probe for read-only sessions

Noerr (3):
      [bindings/python] Add a PriceSource enum for gnc_price_set_source()
      [bindings/python] Fix and modernize the price example scripts (Bug 799796)
      [bindings/python] Deprecate set_source_string; remove it from the Guile bindings

PRG-112 (10):
      Enhancement - making the tooltip more readable (https://bugs.gnucash.org/show_bug.cgi?id=799799)
      Enhancement - Cash Flow report - a configurable visibility of the list of accounts
      Enhancement 799798 - bringing back the previous tooltip (from 4.x) as a configurable choice (https://bugs.gnucash.org/show_bug.cgi?id=799798)
      Better user-facing text.
      Several fixes as per Christopher's input
      Enhancement - tooltip - a non-zero-values filter
      Enhancement - New global properties for CHARTS (GC's level)
      CI Tests - Fix
      Enhancement - even more readable tooltip
      Tweaks and cleanups

Pedro Albuquerque (1):
      Translation update  by Pedro Albuquerque <pmra at protonmail.com> using Weblate

Roy Hansen (2):
      Sort Id columns naturally in gnc-tree-views.
      Sort Id columns naturally in qof-query, which is used in gnucash search

Sherlock (22):
      Bug 799753 - Reconciliation error when reconciling transactions posted after the reconcile date
      Add adjusted_amount field to split
      Improve stock-split type detection
      Determine the adjusted_amount for each split in an account
      use adjusted_amount in place of amount
      Improve code reuse
      Improve readability of dialog-lot-viewer
      Exclude stock-splits from Split views in Lot Viewer
      Add "Show stock split adjusted amounts" check box
      Only show the “Show stock split adjusted amounts” checkbox when there are stock splits
      Remove unused declaration
      Lot Viewer "Amount" and "Balance" columns should not display the currency symbol.
      Reuse lv_refresh()
      Bug: Lot Viewer should watch and handle the account's events
      Lot viewer should display the current name of the account in the window title.
      Partial cleanup of Lot Viewer's lot and split list populate functions
      Bug:  Gain/Loss displayed in "Splits free" is not correct
      The lot scrubber should exclude stock-split splits.
      Bug: Split type field is not being maintained appropriately
      Bug: Missing account event
      Miscellaneous cleanup
      Bug 799790: Always put Debits before Credits for CSV register export (order transaction splits as shown on screen)

Szia Tomi (8):
      Translation update  by Szia Tomi <sziatomi01 at gmail.com> using Weblate
      Translation update  by Szia Tomi <sziatomi01 at gmail.com> using Weblate
      Translation update  by Szia Tomi <sziatomi01 at gmail.com> using Weblate
      Translation update  by Szia Tomi <sziatomi01 at gmail.com> using Weblate
      Translation update  by Szia Tomi <sziatomi01 at gmail.com> using Weblate
      Translation update  by Szia Tomi <sziatomi01 at gmail.com> using Weblate
      Translation update  by Szia Tomi <sziatomi01 at gmail.com> using Weblate
      Translation update  by Szia Tomi <sziatomi01 at gmail.com> using Weblate

Thomas Teixeira (1):
      Bug 799774 - Import transaction from CSV skips fields if CSV

Yegor Derevenets (1):
      Translation update  by Yegor Derevenets <yegor.derevenets at gmail.com> using Weblate

Zhaoquan Huang (3):
      Translation update  by Zhaoquan Huang <zhaoquan2008 at hotmail.com> using Weblate
      Translation update  by Zhaoquan Huang <zhaoquan2008 at hotmail.com> using Weblate
      Translation update  by Zhaoquan Huang <zhaoquan2008 at hotmail.com> using Weblate

ales-ro (5):
      Translation update  by ales-ro <bianaless6 at gmail.com> using Weblate
      Translation update  by ales-ro <bianaless6 at gmail.com> using Weblate
      Translation update  by ales-ro <bianaless6 at gmail.com> using Weblate
      Translation update  by ales-ro <bianaless6 at gmail.com> using Weblate
      Translation update  by ales-ro <bianaless6 at gmail.com> using Weblate

copystring (2):
      Add option to import AqBanking noted transactions
      L10N:de: Translate AqBanking noted transaction option





More information about the gnucash-changes mailing list