Help getting GnuCash with Chipcard HBCI to work on SuSE 8.1

Christian Stimming stimming at
Don Jan 23 16:50:55 CST 2003

Christian Gatzemeier wrote:

> I will try two banks that are new for openHBCI AFAIK. (Nord/LB and 1822direkt)  
> The 1822direkt bank (subdivision of Frankfurter Sparkasse) supplies a userid  
> "Benutzerkennung" with the hbci-paperwork. I know their bankid (Bankleitzahl)  
> and could read their server's address  from the chipcard. ( is  
> this a generic Sparkassenserver? ) For the customer id I tried to enter the  
> same userid xor my regular customer number.   
> In both cases when trying to get the accountlist the message after two pin  
> prompts from the card terminal is:  
> gnc_hbci_api_execute: Error at executeQueue: could not select context (owner2)  

If the bank only gives you a user id ("Benutzerkennung") but no customer 
id ("Kundennummer" or "Kunden-ID"), then your customer id is the same as 
the user id.

However, in case of a chip card the relevant IDs are stored on the card. 
IIRC you can use the tool hbcicard from the libchipcard package to read 
both the user id and the customer id from the card. In that case you 
*must* use the user/customer id as read from the card. The error message 
"could not select context" means that some part of your 
user/bank/customer id does not match the one stored on your card.

For further questions on HBCI-Card issues, you can ask (in German) on 
gnucash-de at or openhbci-general at .

>>However, if the  
>>openhbci-test at configure time fails, it means that there is some  
>>deeper problem with your openhbci installation  
> I see.  
> I found --disable-openhbcitest in another thread and thought the test might be  
> temporarily broken or so. 

 > And config.log has gathered the following:
 > ----------------------------------------------------
 > [...]
 > configure:11030: checking for OpenHBCI
 > configure:11095: checking for OpenHBCI - version >= 0.9.4
 > configure:11172: gcc -o conftest -g -O2 -Werror -I/usr/local/include
 > -I/usr/local/include/chipcard    conftest.c -L/usr/lib -lcrypto -ldl
 > -L/usr/local/lib -lchipcard -L/usr/lib -lcrypto -lopenhbci -lstdc++
 > -L/usr/local/lib -lopenhbci -lm  1>&5
 > cc1: changing search order for system directory "/usr/local/include"
 > cc1:   as it has already been specified as a non-system directory

Oops. Well, in this case the --disable-openhbcitest option is indeed the 
right workaround to get things going. Anyway I think this is fixed in 
current CVS.

> I tried to pay attention to allways "make uninstall" in a sourcetree on my  
> system prior to any new attempts. Could this still be critical?  
> I found out that i.e. /usr/local/bin/openhbci-config does not get rm-ed with  
> this.  

I don't trust "make uninstall" anyway, so I don't check whether the 
settings for that are correct or not. However, if you compiled&installed 
openhbci with --prefix=/usr/local/openhbci, then the script 
openhbci-config should get installed in 
/usr/local/openhbci/bin/openhbci-config and I guess it gets removed from 
there, too. The SuSE 8.1 rpm of openhbci, however, installs with 
--prefix=/usr/bin .