Compile Error

Charles M. Gagnon
Mon, 24 Jul 2000 08:22:14 -0400

It worked... Thanks Dave.

Now I do get a news error though. It could be cause by the
system I have, I'm not sure:

  make[3]: Entering directory
  gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src
  -I../../src/calculation   -I../../src/engine
  -I../../src/g-wrap   -I../../src/guile
  -I../../src/register   -I../../src/register/gnome    -g -O2
  -Wall -I/opt/gnome/include -DNEED_GNOMESUPPORT_H
  -I/opt/gnome/lib/glib/include -I/usr/openwin/include
  -I/usr/local/include -I/usr/local/include -c window-html.c
  window-html.c: In function `gnc_html_print':
  window-html.c:1138: request for member `meta' in something
  not a structure or union
  make[3]: *** [window-html.o] Error 1
  make[3]: Leaving directory
  make[2]: *** [all-recursive] Error 1
  make[2]: Leaving directory `/home/charlesg/src/gnucash/src'
  make[1]: *** [all-recursive] Error 1
  make[1]: Leaving directory `/home/charlesg/src/gnucash'
  make: *** [all-recursive-am] Error 2

I'm still trying to compile the CVS 1.5 of gnucash on a
Solaris 8 system.

BTW, I tried the compiled on a brand new system and I
noticed a couple of things. For:

    - g-warp
    - gnome-print
    - gtkhtml

./configure will go through fine even if the packages are not
available. The error will show up at compile time only.
Shouldn't configure look for these things and complain if
it's not available?


On Sat, Jul 22, 2000 at 01:16:55PM -0700, Dave Peticolas wrote:
> "Leach, Chris J (Oakton)" writes:
> > _N is the problem
> I have renamed that function, as well as the other short functions
> in src/calculation, so that should fix things.
> thanks,
> dave

Charles Gagnon                   | My views are my views and they             | do not represent those of anybody           | but me.

   And whose cruel idea was it to put an "S" in the word "Lisp"?
        -- Dennis Miller