Problems compiling latest unstable

Dave Peticolas
Fri, 02 Feb 2001 19:31:13 -0800

Richard -Gilligan- Uschold writes:
> --------------B465DD137215E6E4EBE66C4B
> Content-Type: text/plain; charset=us-ascii
> Content-Transfer-Encoding: 7bit
> I've been trying to compile the latest unstable version all year.  I've
> tried the suggestions offered here, but still have problems.  The
> current error, below, is the same as I had Jan 27.  This was based on a
> completely new download of the cvs tree on Jan 28.  The current versions
> of all packages I've installed / updated since I began working on
> gnucash are below.
> get all new copy of latest:
> cvs -d login
> cvs -z3 -d co gnucash
> make distclean   (Note: this does remove config.cache)
> ./ --enable-opt-style-install --disable-guppi
> --prefix=/opt5.3  > & autogen.err.txt
> make >& make.err.txt
> gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src
> -I../../src/calculation   -I../../src/engine   -I../../src/g-wrap
> -I../../src/guile   -I../../src/register   -I../../src/register/gnome
> -I/usr/include -DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include
> -I/usr/lib/glib/include -I/usr/X11R6/include   -I/usr/include    -g -O2
> -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations  -Wall
> -Werror-implicit-function-declaration
> -I/usr/local/include          -I/usr/include -DNEED_GNOMESUPPORT_H
> -I/usr/lib/gnome-libs/include -I/usr/lib/glib/include
> -I/usr/X11R6/include -I/usr/include/gnome-xml          -I/usr/include
> -I/usr/lib/glib/include -DNEED_GNOMESUPPORT_H
> -I/usr/lib/gnome-libs/include -I/usr/X11R6/include
> -I/usr/include/gnome-xml -DGTKHTML_HAVE_PSPELL   -I/usr/include     -c
> gnc-html.c
> gnc-html.c: In function `gnc_html_object_requested_cb':
> gnc-html.c:680: implicit declaration of function `unescape_newlines'
> gnc-html.c:680: structure has no member named `data'
> gnc-html.c:680: warning: initialization makes pointer from integer

You need gtkhtml-0.8. Mandrake packages are available at

You need the -devel version as well, and the packages probably
require some of the other packages in that same directory.

> Can't install these:
> Guppi-0.35.2-1.i586.rpm
> glibc-2.2.1-3mdk.i586.rpm
> glibc-devel-2.2.1-3mdk.i586.rpm
> bonobo-0.33-2mdk.i586.rpm
> rpm error message:
> "only packages with major numbers <=3 are supported by this version of
> RPM"

Those rpms were created by rpm 4.0. I'm not sure where you would get
Mandrake rpms for rpm 4.0. I think there might be an update to rpm 3.0
that allows it to read the new format, but I'm not sure.