Bug in the register value entry

David Hampton hampton@employees.org
28 Apr 2002 15:06:01 -0700

Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable


I tried this in a copy of gnucash-1.6 built from the gnucash-1-6-branch
tag in CVS and didn't see your problem.


P.S. Congratulations.

On Wed, 2002-04-17 at 19:02, Conrad Canterford wrote:
> In gnucash 1.6.6, locally compiled, guile-1.4 and g-wrap 1.1.9.
> I have found a problem with the data entry into the debit/credit fields
> of the register. If I enter the simple arithmetic statement:
> 22.32*2+16.8+34.2*2+18.81+85.44-42.72+13.32+15.48+23.4+115.4
> into the Debit field, the result I get back (after some computational
> burden on the processor) is not correct and in all 3 instances I've seen
> so far has been a negative number (two quite large, one small). I
> believe that it is negative because it ends up in the credit field, even
> though I entered the above into the debit field.
> I'm guessing we're getting memory corruption in one of the register
> structures, as any attempts to modify the values were giving various and
> different results. Deleting the split and re-entering it without the
> subtraction component in it worked. I could then do the subtraction
> seperately without problems.
> I will be a bit short on time in the next 3 days, and then will be away
> for 2 weeks after that (a wedding and honeymoon does that), but am very
> happy to help isolate and identify as time permits.
> Conrad.

Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org