Build Problems

Hal Goldfarb halg at
Sat Feb 19 02:53:31 EST 2005

I feel ashamed to ask this, being I am a 10+ year Configuration Manager on a 
number of projects.  Only problem is, for the most part, I was not building 
GNU tools (there always seemed to be someone to do that part).  But I am very 
familiar with build tools, having written a few, and having worked for a 
company that produced build tools.

Trouble I am having is this:  I am trying to build gnucash from scratch on my 
Mandrake 10.1/x86 system.  I do the following:

cvs -d :pserver:cvs at checkout gnucash 

which works fine.  Then

autoupdate  so I can get into a format compatible with my 
autoconf, which is 2.5/2.59 (I was getting about a dozen errors if I did not 
run autoupdate first).  That works OK, then:


with no arguments (that could be my problem?).   Here is the output: error: m4_popdef: undefined macro: AC_Dest
autoconf/status.m4:848: AC_CONFIG_FILES is expanded from... the top level
autom4te-2.5x: /usr/bin/m4 failed with exit status: 1

Since (apparently) other folks are not having this problem with the build (or 
I am sure I would have seen something in the archives about it; I did check), 
this might have something to do with my specific development environment.

So I decided to investigate if this might be the case.  I ran autoconf with 
the tracing turned on, and copy-and-pasted the output to a new text file.  I 
did some editing so I could see just the relevant portion of the m4 


echo calling m4:

/usr/bin/m4 --nesting-limit=4096 --include=/usr/share/autoconf --debug=aflq 
--fatal-warning --trace=AC_CONFIG_FILES 
--reload-state=/usr/share/autoconf/autoconf/autoconf.m4f configure.hal

Note that I copied to a work copy so I could test stuff out.  I 
got basically the same output as before, but with the trace detail.  Finally, 
I removed the reload-state option, just to see what happens (I know, I know, 
but give me a moment here).   I get a message (in red) at the end of the 
output (on stderr) :

  # Enable error-on-warning by default -- I'm tired of fixing other
  # people's missing #includes, etc.
    [  --disable-error-on-warning    disable treating compile warnings as 
    [case "${enableval}" in
       yes) warnFLAGS="${warnFLAGS} -Werror" ;;
       no)  ;;
       *) AC_MSG_ERROR(bad value ${enableval} for 
--enable-error-on-warning) ;;
       [  warnFLAGS="${warnFLAGS} -Werror" ])

  # For gcc >= 3.4.x, specifically enable the new warning switch
  # -Wdeclaration-after-statement in order to preserve source code
  # compatibility to gcc 2.95 and other compilers.
  GCC_VERSION=NONE:0: /usr/bin/m4: ERROR

Ok, so it looks like m4 is coughing?  Maybe problem with that particular 
enable option; but, no, I edited my work copy of the file and 
moved this option toward the top, before the preceding options are generated.  
Same problem, just a different enable option.  I also tried playing with the 
options in my little shell script (above), but to no avail.

What am I doing wrong?  And for that matter, is my analysis thorough enough 
for this board?  Am I making the fatal mistake that every newbie to GNU 
builds makes?  (Probably.  Probably something really dumb.)  Sorry if this is 
long, but I felt I should do some research before pestering everyone.

More info on my setup:
Mandrake 10.1 with all patches from mandrake
m4 version 1.4.1
automake 1.9
g-wrap 1.3.4

One more thing:  I know that you have to install the *-devel packages for 
everything to work correctly.  But I also had problems with doing that.  For 
instance, when I was running configure from the tarball, not doing my own 
autoconf, it would complain that it could not find -libgal, but it is in fact 
installed (libgal23, in fact).  Go ahead, fill me in.  And please remember to 
shoot me if this was already discussed elsewhere in the mailing lists.

Appreciate your help,
(once-proud buildmeister of Unix utilities and tools)

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the gnucash-devel mailing list