Problem building gnucash (G2)

David Hampton hampton-gnucash at
Sun May 1 16:38:18 EDT 2005

On Sun, 2005-05-01 at 20:32 +0100, Neil Williams wrote:
> On Sunday 01 May 2005 8:05 pm, Phil Longstaff wrote:
> > From what I have seen using Google, this may be because I have an older
> > version of glib in my link path.  I do have both glib-1.2.10 and
> > glib2-2.4.0 installed and can't uninstall them.

You might be right.  I have a test system running FC3 has glib2-2.4.8
and I don't see the function there.

  $ objdump -T | grep g_assert

I have another FC3 system with newer libraries including glib-2.6.0 and
I do see the function there.

  $ objdump -T | grep g_assert
  00594573 g    DF .text  00000077  Base        g_assert_warning

I haven't tried to compile on the first system, only the second.  Is
anyone who is able to compile g2 using glib2-2.4.x?

> ? Why can't you uninstall glib-1.2.10?

Bzzt.  Sorry, wrong answer.  This library is required for gnucash 1.8.
Glib1 and 2 were designed so they could both be installed at the same


More information about the gnucash-devel mailing list