Build failure: Ubuntu 6.06 CVS

Nigel Titley nigel at
Wed Aug 9 10:19:09 EDT 2006

Anybody any idea what is causing the below. This is on Ubuntu 6.06, 
fully patched and is the latest CVS. Gnucash has successfully compiled, 
built and run on this system before, but when I did an update today and 
tried to rebuild it came up with the error below. I tried loading a 
virgin copy of CVS, but still get the same error.

Configure was invoked with

./configure --enable-ofx --enable-opt-style-install --prefix=/opt/gnucash

make[5]: Entering directory 
/bin/sh ../../../../libtool --tag=CC --mode=link gcc  -g -O2 -Wall 
-Wunused -Wmissing-prototypes -Wmissing-declarations   -Werror 
-Wdeclaration-after-statement            -Wno-pointer-sign 
-D_FORTIFY_SOURCE=2   -o test-link  test-link.o 
../ ../../../../src/gnome/ 
../../../../src/app-utils/ -lxml2 -lz -lm   
../../../../lib/libqof/qof/ -lpopt -lm  -lm
gcc -g -O2 -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations 
-Werror -W           declaration-after-statement -Wno-pointer-sign 
-D_FORTIFY_SOURCE=2 -o .libs/test-           link test-link.o  
/usr/lib/ -lz ../../../../lib/libqof/qof/.libs/ 
/usr/lib/ -lm -Wl,--rpath -Wl,/opt/gnucash/lib/gnucash 
-Wl,--rp           ath -Wl,/opt/gnucash/lib
../../../../src/gnome-utils/.libs/ undefined 
reference to `gnc_cbe_add_completion'
../../../../src/gnome-utils/.libs/ undefined 
reference to `gnc_cbe_set_by_string'
../.libs/ undefined reference to 
`gnc_cbe_require_list_i           tem'
collect2: ld returned 1 exit status
make[5]: *** [test-link] Error 1
make[5]: Leaving directory 
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory 
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/nigel/src-new/gnucash/src/import-export'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/nigel/src-new/gnucash/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/nigel/src-new/gnucash'
make: *** [all] Error 2

More information about the gnucash-devel mailing list