building from SVN on MacOS -- make check fails?

Derek Atkins warlord at MIT.EDU
Tue Dec 26 10:20:08 EST 2006

Hi to all you MacOS developers.

I decided to help Andreas test some code on MacOS so I pulled
down his branch, built it, and was trying to run a "make check".
But it failed!  So I tried trunk.  "make check" failed there, too!
So I wanted to try 2.0, and it even failed THERE, too!

So now I'm confused...

I'm using MacPorts; I installed 2.0.2 via macports, and I had
to install a few extra packages to build from SVN, but not too many.
But I'm wondering if I'm missing something to get "make check"

When I run "make check" I get dlopen failures.  For example:

** (process:5220): WARNING **: Failed to dlopen() '../../../src/gnc-module/test/mod-foo/': dlopen(../../../src/gnc-module/test/mod-foo/libgncmodfoo.0.dylib, 9): image not found

Obviously here it's looking in the wrong place; the .dylib is in
...test/mod-foo/.libs/libgncmodfoo.0.dylib, but I don't know
why it's missing the .libs path.

Building from trunk is even stranger!  I get:

ERROR: In procedure dynamic-link:
ERROR: file: "libguile-srfi-srfi-13-14-v-1", message: dlopen(, 9): image not found"

Strange that in trunk it's looking for a .so and not a .dylib!

Any MacOS help would be greatly appreciated!


       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL:    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the gnucash-devel mailing list