Guile 1.8 error

Mike Alexander mta at
Fri Dec 28 19:43:43 EST 2007

--On December 27, 2007 1:47:02 AM -0500 Mike Alexander <mta at> 

> With these changes Gnucash loads and more or less runs, but when I
> tried to update quotes it hung trying to spawn the process to run the
> Perl script.  The top of the stack is
> #0  0x900148a4 in read ()
> #1  0x02ba8550 in read_ints ()
> #2  0x02ba92f0 in fork_exec_with_pipes ()
> #3  0x02ba99ac in g_spawn_async_with_pipes ()
> #4  0x007883b0 in gnc_spawn_process_async (argl=0x9f1a930,
> search_path=1) at
> ../../../../gnucash-2.0/src/app-utils/guile-util.c:1222
> #5  0x00776f84 in _wrap_gnc_spawn_process_async (s_0=0x18, s_1=0x104)
> at swig-app-utils.c:1905
> #6  0x0287bea4 in deval (x=0x404, env=0x64c1760) at eval.c:4349
> #7  0x02877dbc in deval (x=0x63135f8, env=0x64c1760) at eval.c:3689
> #8  0x0287deec in scm_dapply (proc=0x64c1860, arg1=0x404,
> args=0x64c1760) at eval.c:5001
> #9  0x02870394 in scm_apply (proc=0x64c1850, arg1=0x404, args=0x404)
> at eval.c:4800
> #10 0x0286fee0 in scm_call_0 (proc=0x64c1850) at eval.c:4655
> #11 0x02859788 in scm_dynamic_wind (in_guard=0x64c1850,
> thunk=0x64c1820, out_guard=0x64c17f0) at dynwind.c:104
> This is where I'm giving up.  I'll go back to guile 1.6, but I
> thought I should record what I've learned.

This appears to be a GLib problem, not a Guile problem (which isn't too 
surprising, I guess).  If I use GLib 2.14.4 from MacPorts it hangs like 
this, but if I use 2.14.2 it doesn't.  There aren't any changes between 
these versions that look relevant, and the hang doesn't seem to happen 
if I run under gdb, so I suspect it's timing related.  Perhaps some 
sort of race condition between the Gnucash process and the spawned 

Mike Alexander           mta at
Ann Arbor, MI            PGP key ID: BEA343A6

More information about the gnucash-devel mailing list