Windows Compilation Error: gconftool-2

Tom Purl tom at
Sat Jan 6 20:51:27 EST 2007

I'm trying to install GnuCash from source on Windows XP SP 2.  I get to the following point when I run in debug mode:

    ++ popd
    ++ qpushd /c/soft/gnucash/inst/etc/gconf/schemas
    ++ pushd /c/soft/gnucash/inst/etc/gconf/schemas
    ++ gconftool-2 --config-source=xml:merged:c:/soft/gnucash/inst/etc/gconf/gconf.xml.defaults --install-schema-file apps_gnucash_dialog_business_common.schemas

At this point, an empty DOS command window pops up with the following title:


The installation script seems to hang at this point.  I've waited over half an hour for something to happen twice, and it just hangs.

I don't seem to have a gconf.xml.defaults folder in my c:/soft/gnucash/inst/etc/gconf folder.  I only have a "schemas" folder there.  

I then copied the gconf.xml.defaults folder from a different location to that directory, and I got the following error when I ran again:

     gcc -DHAVE_CONFIG_H -I. -I../../../../../repos/lib/libqof/backend/file -I../../../.. -I../../../.. -I../../../.. -I../../../.. -I/c/soft/autotools/include -I/c/soft/regex/include -I/c/soft/gnome/include -I/c/soft/guile/include -D_WIN32 -I.. -I../.. -DLOCALE_DIR=\"c:/soft/gnucash/inst/share/locale\" -I../../../../lib/libqof/qof -I../../../../../repos/lib/libqof/qof -Ic:/soft/gnome/include -Ic:/soft/gnome/include/glib-2.0 -Ic:/soft/gnome/lib/glib-2.0/include -I../../../../../repos/lib/libc -Werror -Wdeclaration-after-statement -g -O2 -g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wno-unused -MT qsf-xml.lo -MD -MP -MF .deps/qsf-xml.Tpo -c ../../../../../repos/lib/libqof/backend/file/qsf-xml.c  -DDLL_EXPORT -DPIC -o .libs/qsf-xml.o
    /bin/sh ../../../../libtool --tag=CC --mode=link gcc -I.. -I../.. -DLOCALE_DIR=\""c:/soft/gnucash/inst/share/locale"\" -I../../../../lib/libqof/qof -I../../../../../repos/lib/libqof/qof -Ic:/soft/gnome/include -Ic:/soft/gnome/include/glib-2.0 -Ic:/soft/gnome/lib/glib-2.0/include   -I../../../../../repos/lib/libc -Werror -Wdeclaration-after-statement -g -O2 -g -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations  -Wno-unused  -L/c/soft/autotools/lib -L/c/soft/regex/lib -L/c/soft/gnome/lib -L/c/soft/guile/lib -g -no-undefined -o -rpath c:/soft/gnucash/inst/lib -module -avoid-version qsf-backend.lo qsf-xml-map.lo qsf-xml.lo ../../../../lib/libqof/qof/ -Lc:/soft/gnome/lib -lgthread-2.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -liconv   -lregex -Lc:/soft/gnome/lib -lxml2 -lz   ../../../../lib/libc/ -lpopt -lm  -lm
    libtool: link: `qsf-xml-map.lo' is not a valid libtool object
    make[7]: *** [] Error 1
    make[7]: Leaving directory `/c/soft/gnucash/build/lib/libqof/backend/file'
    make[6]: *** [all-recursive] Error 1
    make[6]: Leaving directory `/c/soft/gnucash/build/lib/libqof/backend/file'
    make[5]: *** [all] Error 2
    make[5]: Leaving directory `/c/soft/gnucash/build/lib/libqof/backend/file'
    make[4]: *** [all-recursive] Error 1
    make[4]: Leaving directory `/c/soft/gnucash/build/lib/libqof/backend'
    make[3]: *** [all-recursive] Error 1
    make[3]: Leaving directory `/c/soft/gnucash/build/lib/libqof'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/c/soft/gnucash/build/lib'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/c/soft/gnucash/build'
    make: *** [all] Error 2

Is this a bug, or is there some mistake that I'm making?


Tom Purl

More information about the gnucash-devel mailing list