Problems downloading stock quotes

Richard Geddes rich.geddes at
Sat Oct 13 16:16:02 EDT 2007

I was using GNUCash 2.0.5 on Ubuntu 7.04 for the last several months.  Set up some stock investments and downloaded stock prices with Tools -> Price Editor -> Get Quotes.  This worked ok until about 3 weeks ago.  Now I get a message "There was an unknown error while retrieving the price quotes." 

I did install a firewall management program called "Firestarter" between the time gnucash was working and when it stopped working... I've since  uninstalled Firestarter.  I tried getting stock quotes after stopping my firewall using "/etc/init.d/iptables stop".  No difference.

I also upgraded to gnucash 2.2.1.  No dice.

I uninstalled gnucash altogether and reinstalled it, but still getting the same message.

I even thought of uninstalling perl as the module gnucash uses to get the quotes is in perl... but, it seems that many apps on my system depend on perl... on my ubuntu system, if I try to uninstall perl, it also includes (to uninstall) pretty much all the apps I've installed.. does that sound correct...?  

Anyway, my beef isn't really with perl, although it seems that if there was something goes wrong with perl, alot of things depending on it would also go down.... I just want to get my stock quotes so I can see my current asset values to make decisions without pulling out the calculator.

Can someone help me troubleshoot this problem?  Thanks.


More information about the gnucash-devel mailing list