can't print checks on trunk?

David Reiser dbreiser at
Tue Apr 8 21:52:18 EDT 2008

On Apr 8, 2008, at 2:47 PM, Derek Atkins wrote:

> Hey all,
> I just tried to print a check (for the first time in about 4 1/2
> months) and noticed that it wasn't working.  This is on a
> Fedora 7 machine.  I know it USED to work (4 1/2 months ago).
> If I try to print directly to the printer the dialog sticks
> around for a while and it DOES send something, but it never prints.
> If I print to a file and choose Postscript it generates what
> appears to be empty postscript.  However if I print to PDF it
> does create a valid PDF that I can then print (from acroread).
> Unfortunately I don't know exactly when this might have changed.
> The GnomePrint subsystem still prints reports out okay (I can print a
> report), so it's only the GtkPrint subsystem that's having an issue.
> :(
> Has anyone else noticed this?  (I'm currently building the 2.2
> branch to test if it's working there, which would tell me if
> it's just something in trunk or (maybe) a problem with my version
> of gtk.  Maybe I'll pull in the Fedora updates.
> -derek

I just printed a check from trunk r17069 and it worked fine. I'm using  
gtk+ 2.12.8. I can tell I'm using gtkprint because the printer  
selection dialog actually works.

David Reiser
dbreiser at

More information about the gnucash-devel mailing list