Problems building GNUCash 2.2.3

John M Collins jmc at
Fri Feb 22 03:36:04 EST 2008

Please CC replies to jmc AT xisl DOT com as I'm not subscribed.

On Thu, 2008-02-21 at 18:13 -0500, Derek Atkins wrote:

> Hi,

> > I am trying to build GNUCash 2.2.3 on my Opteron machine which is
> > running Mandriva 2007.0
> >
> > I hit some problems with it crashing on startup and searching your
> > archives I see you advised someone else to get newer versions slib and
> > guile, both of which I've done apparently without problems
> >
> > The version of guile is 1.8.4
> I'd recommend you downgrade guile to an earlier version, perhaps
> 1.8.1 or even 1.6.

I've tried putting in 1.8.1 but then configure on GNUCash thinks it
can't find SLIB any more????
I tried forcibly reinstalling SLIB after installing Guile 1.8.1 but it
still thinks it's not there.

I'm a bit nervous about using 1.6 as the version Mandriva supplied was
1.6.8 and GNUCash built with that crashes on startup for me at any rate.

Maybe the crash on startup built with that has some other cause I
suppose. I'm getting progressively disillusioned with Mandriva. I always
seem to hit problems like this every time I try to build up-to-date
versions of stuff.

> >
> > Thanks for any help.
> >
> > John Collins, Welwyn Garden City, UK
> >
> > P.S. I also hit a problem building he pixmaps but I commented a bit out
> > of the Makefile in the pixmaps directory and it seemed OK after that.
> > The problem isn't there in GNUCash 2.2.2.
> What problem?

This problem. I got round it by commenting out the build of

Making all in pixmaps
make[3]: Entering directory `/home/downloads/gnucash-2.2.3/src/pixmaps'
mkdir -p 32x32
cp ./gnucash-icon-32x32.png 32x32/gnucash-icon.png
mkdir -p 48x48
cp ./gnucash-icon-48x48.png 48x48/gnucash-icon.png
make[3]: *** No rule to make target `scalable/gnucash-icon.svg', needed
by `all-am'.  Stop.
make[3]: Leaving directory `/home/downloads/gnucash-2.2.3/src/pixmaps'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/downloads/gnucash-2.2.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/downloads/gnucash-2.2.3'
make: *** [all] Error 2

Thanks for any help anyone can give.

John Collins
Welwyn Garden City, UK

More information about the gnucash-devel mailing list