DBI/SQL backend

Phil Longstaff plongstaff at rogers.com
Thu Jun 12 08:09:43 EDT 2008

I need to disable that by default.  Build with --disable-gda.


----- Original Message ----
From: Karim B <karimb at comcast.net>
To: nbinont at yahoo.ca; gnucash-devel at gnucash.org
Sent: Thursday, June 12, 2008 6:53:01 AM
Subject: Re: DBI/SQL backend

Nathan Buchanan wrote:
> On Wed, Jun 11, 2008 at 8:58 PM, Phil Longstaff <plongstaff at rogers.com>
> wrote:
>> I think the DBI/SQL backend is ready to try.  It is in the gda-dev2
>> branch.  The GDA backend has been disabled and a DBI backend is enabled.
>>  It assumes that the include files are in /usr/include/dbi/dbi.h and the
>> driver files are in /usr/lib/dbd.  The only driver that the DBI backend
>> supports is sqlite3.  I am using libdbi-0.8.2.  I assume later versions
>> will work.  I don't know about earlier versions.  There is a compilation
>> check that the header file is present, but no version check.
> Great News!
>> No new URI types have been added.  If you try to open a file, it will
>> check if it is an sqlite3 file, and will load it with sqlite3.  If it
>> can't, it will revert to xml.  Save As will save a file as an sqlite3
>> file.  The "Connect to Database" menu entry is still enabled but will
>> (probably) fail.
>> I don't have a windows compilation environment, so I haven't tried it on
>> windows.
> I'll see what I can do to get it working under windows (unless someone beats
> me to it! Lots of stuff going on atm...)
> Nathan
>> Please feel free to try it out and report any problems.  This is not yet
>> ready for your real data, though it would be a good test to load your
>> xml file and save-as an sqlite3 file.
>> Phil
>> _______________________________________________
>> gnucash-devel mailing list
>> gnucash-devel at gnucash.org
>> https://lists.gnucash.org/mailman/listinfo/gnucash-devel
I tried to building the gda-dev2 branch  on windows and got this error:

    checking for LIBGDA... configure: error: Package requirements 
(libgda-4.0 >= 3.99.2) were not met:
    No package 'libgda-4.0' found

I went to the libgda web site but didn't see a download for 
libgda-4.0.  does the gda branch require libgda-4.0?  Or is there 
something I need to adjust?

Let me know and I'll try it again.  Thanks.
gnucash-devel mailing list
gnucash-devel at gnucash.org

More information about the gnucash-devel mailing list