Trading accounts change (bug 537476)

Mike Alexander mta at
Wed Dec 2 15:55:47 EST 2009

I'm still at a loss to know why my recent change to define the values 
in C and export them to Guile using Swig fails for you but not for me. 
I tried building GnuCash with guile 1.6.8 and swig 1.3.36 (which are 
the versions you said you are using) and it worked fine.  I also tried 
running it in a German locale, just in case that mattered, and it still 
worked fine.  There must be some other difference between your 
environment and mine that is causing the problem.

I'm afraid I'm going to need some help tracking this down since I can't 
reproduce the problem.  Could you send me the swig-engine.c file 
generated when the failing version of GnuCash was built?  I'd like to 
see how it differs from mine.  Maybe that will suggest something else 
to try.  Also, if it's not too much trouble, perhaps you could try 
checking out a clean copy and rebuilding from scratch to see if that 
changes anything.  Another thing that might be worth trying is to 
define SWIGRUNTIME_DEBUG when compiling swig-engine.c to see if it 
produces any useful output.

Sorry I can't be of more help, but I think I really need more 
information to track this down.  Has anyone else tried this patch?  If 
so did it work or did you have a similar problem?  Perhaps I can detect 
a common thread among environments where it failed.


More information about the gnucash-devel mailing list