Proposal for Save As.../Open dialog

Geert Janssens janssens-geert at
Mon Dec 14 17:26:41 EST 2009

On Sunday 13 December 2009, Christian Stimming wrote:
> Am Samstag, 12. Dezember 2009 schrieb Derek Atkins:
> > Geert Janssens <janssens-geert at> writes:
> > > I believe 2.10 was more or less agreed upon as the minimum version
> > > (given that this is the version used in RHEL 5). There was never a
> > > formal confirmation of this, though. Perhaps this is a good time to
> > > decide on this ?
> > > If 2.10 is still too recent, glade can also generate code compatible
> > > with 2.8.
> >
> > Right now configure checks for a minimum version of Gtk 2.6.
> > We should fix the configure script, but I'd propose nothing newer than
> > 2.10, but if we can keep it at 2.8 that would be better.  The earlier
> Geert: Would gtk 2.8 be sufficient? You could increase the
> version, then. Otherwise 2.10 is fine with me, if this is really our
> requirement to be able to work with the glade files (which we of course
> need to be able to).
> Christian

I verified my dialog against 2.8. It's fine. I expect it to be fine on 2.6 as 
well, but I can't test this.

I didn't do anything fancy. My changes were mostly rearranging the widgets 
that were there already. The only widget I actually added was the "Data 
format" label.

I agree that GnuCash shouldn't require higher gtk version numbers just because 
we can. I chose to up the minimum version to 2.8 though, simply because I can 
verify against that version in the current Glade release.

I quickly verified on distrowatch as well. None of the distributions we 
"support" (Ubuntu, openSuse, Fedora,...) still has support for 2.6. All of 
them abandoned 2.6 somewhere in 2005. This means 
a) it is already hard for us to test the GnuCash dialogs actually running in a 
gtk+2.6 environment
b) someone that is still running a gtk+2.6  based distribution shows a rather 
conservative attitude towards software updates, so I would doubt this person 
would be interested in migrating to GnuCash 2.4.x. Remember that when gtk+2.6 
was actual, GnuCash was still 1.8.x !

Of course, if you disagree I can revert the requirement...


More information about the gnucash-devel mailing list