make check failing on mac leopard

Charles Day cedayiv at
Wed Feb 25 12:04:19 EST 2009

On Wed, Feb 25, 2009 at 7:22 AM, David Reiser <dbreiser at>wrote:

> On Feb 19, 2009, at 2:36 PM, Charles Day wrote:
> On Thu, Feb 19, 2009 at 11:10 AM, Charles Day <cedayiv at> wrote:
>> I tried "make check" on my mac today, and it is failing (see below). I
>> assume that this is related to the ".so" vs. ".dylib" thing, to which I hope
>> that Dave can still recall the answer. See:
>> Any bright ideas on what I have to change to fix this?
> Sorry to reply to my own question, but it was solved by adjusting
> export
> DYLD_LIBRARY_PATH="/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/Resources:/opt/local/lib"
> (all on one line)
> This was for libraries built with MacPorts, so I guess it would be
> different with fink.
> [snip]
> A straightforward substitution of the fink libs '/sw/lib' for
> '/opt/local/lib' doesn't work for me.
> I have never managed to get make check to work on my mac. With yesterday's
> trunk, it fails in test-lots at
> OTHER <gnc.lots> [xaccSplitAssignToLot()] Failed to split into two!

The lots failure is an open issue and it presently happens on every platform
so far as I know. So your setup is probably fine.

> The resolution of the thread mentioned above was to remove the sed patch
> pogma mentioned late in the thread.
> The fink wizards are unanimous in warning that DYLD_LIBRARY_PATH should be
> avoided if at all possible. It doesn't do the same thing in OS X that it
> does in Linux, and frequently gets in the way on the
> Mac. DYLD_FALLBACK_LIBRARY_PATH is generally recommended as 'doing what you
> want'. While trunk builds for me without the substitution, for the fink I
> have to replace all of the DYLD_LIBRARY_PATH instances
> with DYLD_FALLBACK_LIBRARY_PATH or gnucash won't build. Fink almost wipes
> your environment before it builds, so something gets out of whack in that
>  step. Doing that substitution in trunk does not solve my make check
> problem.

Thanks, I'll keep an eye out for this if I see any problems. Previously I
was getting GnuCash to run by adjusting DYLD_LIBRARY_PATH in the
"bin/gnucash" script manually. Obviously that trick doesn't work for "make
check", so I just put in the environment before running.

I have tried DYLD_FALLBACK_LIBRARY_PATH, and it didn't work for me. I get a
"make check" failure in the dynamic linking tests.

> Dave
> --
> David Reiser
> dbreiser at


More information about the gnucash-devel mailing list