AqBanking on Win32 - GWEN_TYPE_UINT32 undefined

Peter Hansen peter at
Tue Jun 23 07:18:54 EDT 2009

Gary Bartlett wrote:
> Thank you both Martin and Derek.
> I have now successfully built GnuCash from SVN.  I should note that this
> section in the Windows Wiki <> appears
> to be misleading:
>>    - Either:
>>       - Skip building the AqBanking Setup Wizard by specifying
>>       "AQBANKING_WITH_QT=no"
>>       - Download Qt from,
>>       install it, and set QTDIR in, like
>>       "QTDIR=/c/soft/qt-win-opensource-src-4.4.3". Also, pending integration of
>>       AqBanking3_Porting <>,
>>       set "AQBANKING3=no". To save yourself some pain, get a binary version of QT
>>       such as the ones here<>.
>>       4.2.2 is known to work, though newer versions may work as well. Upon
>>       installation they may warn that mingw is too old (3.2 vs. 3.1) but this
>>       doesn't seem to matter.
> It appears that the only combination that now works is to download/install
> Qt, set QTDIR accordingly, and to *not *set "AQBANKING_WITH_QT=no"
> *nor *"AQBANKING3=no"
> (i.e. build AqBanking 3 with Qt).  Perhaps someone can update the wiki
> accordingly?

I'm coming in late (just joined list, just built GnuCash on Windows for 
the first time), so forgive any errors, but I did just "successfully" 
build with *both* of those set to "no".  (In fact, any attempt to build 
with either set to yes led to issues with downloading or building 
various versions of gwenhywfar or aqbanking, whatever those are.)  I did 
have to figure out to add AQBANKING3=no to to do this.

By "successfully" I mean it runs, with basic XML and SQLite support (was 
really hoping for Postgres, but I see that's a work in progress on win32).

I did have to tweak for gnutls (to 2.8.1 as, I believe, 
2.7.3 wasn't found on the site.

Might have been some other hitches that I overcame, but "svn diff" in 
the packaging folder doesn't show any.  I did have to use work in 
c:/soft only, as no attempt to put stuff elsewhere managed to get me 
past various issues with MSYS and perl and such (mostly issues others 
have noted, if not entirely solved, in various lists and wikis).

This worked on both Vista and an XP Pro box running under qemu.

Peter Hansen, P.Eng.
Engenuity Corporation

More information about the gnucash-devel mailing list