Problems with aging.scm (and guile 1.8?)

Matthijs Kooijman matthijs at
Thu Aug 5 14:58:02 EDT 2010

Hi folks,

I was just trying the Aging Payables report using a current trunk
version, which triggered a few errors here. I don't think backtraces are
relevant, so just the errors:

guile-modules/gnucash/report/aging.scm:311:5: Wrong type (expecting
    exact integer): #<primitive-procedure QOF-QUERY-AND>

guile-modules/gnucash/report/aging.scm:312:5: Wrong type (expecting
    exact integer): #<primitive-procedure QOF-QUERY-AND>

guile-modules/gnucash/report/aging.scm:313:5: Wrong type argument in
    position 2: ("trans" "date-posted")

The first two errors are similar, I solved them by putting parentheses
around QOF-QUERY-AND (which is a function generated by swig that returns
the value corresponding to the constant). Not sure why this was broken.

These errors appeared in turn, the next one when I solved the previous
one. I haven't solved the third error yet :-)

I'm not quite sure why this is broken, since this would probably have
been noticed, right? I don't see any relevant changes in aging.scm, nor
qofquery.h (where QOF_QUERY_AND is defined). The only thing I can think
of, is that I'm running guile 1.8 since this morning (but I don't know
if the report was working with guile 1.6, never tried it...).

Anyone else seeing this problem?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <>

More information about the gnucash-devel mailing list