Mac OS X Snow Leopard AqBanking Does Not Work

Andre Powell apowell656 at
Thu Aug 19 21:31:39 EDT 2010

Thank you for the guidance, the Finder adjustment seems to make it not crash, but it will not save any user information that I add or make it through the acquiring lock process. In the meantime, I will just use 

Andre Powell

On Aug 19, 2010, at 8:55 PM, John Ralls wrote:

> On Aug 19, 2010, at 3:34 PM, Andre Powell wrote:
>> 2.3.15 seems to have fixed a lot of issues and added great features. My only
>> issue is the AqBanking does not work.
>> When I originally tried to download transactions it always fails at aquiring
>> a lock. I am not sure if this is part of the problem but the icon showed
>> QT3-Wizard when I was checking the settings. When I have tried to set any
>> settings the wizard crashed (before 2.3.15 it just required some extra
>> button pushing to go to the next setting).
>> I have uninstalled and reinstalled the application, deleted the aqbanking
>> folder and reinstalled the application, and of course ran the script that
>> was included in the .dmg.
>> Any help would be appreciated.
> Well, that's discouraging. I'd used the new q4banking and q4wizard, and a new build of Qt, in hopes that it would work.
> But, a bit of investigation shows that I missed a step: Gnucash still calls the qt3-wizard, when it should use qt4-wizard. But we can trick it:
> In Finder, right-click (or control-click) on and select "Show Package Contents" in the resulting context menu. Navigate to Contents:Resources:lib:aqbanking:plugins:29:wizards. You'll find 4 files in the folder. Rename the two that start with qt3 to something else (I used qt03, so I have qt03-wizard and qt03_wizard.xml.) Then rename the two that start with qt4 so that they start with qt3 (e.g., qt4-wizard becomes qt3-wizard). Try again.
> If it still crashes, please attach a crash dump (You'll find it in ~:Libary:Logs:DiagnosticReports:qt3-wizard_2010_08_blah_blah_system.crash (where "blah_blah" is the rest of a date-time string and "system" is your computer's name). Be sure to attach the latest one.
> In the meantime, I'll find the right place in Gnucash and fix it to call the right wizard. The qt3 one has part of its interface missing.
> Regards,
> John Ralls

More information about the gnucash-devel mailing list