Patch Re: Bug 625193 To move utils to core

Mike Evans mikee at
Tue Aug 24 03:21:27 EDT 2010

On Monday August 23 2010 21:25:42 Christian Stimming wrote:
> Am Monday 23 August 2010 schrieb Mike Evans:
> > On Monday August 23 2010 18:42:40 Geert Janssens wrote:
> > > Mike,
> > > 
> > > Geert
> > 
> > Hopefully a better (combined) patch.
> Yes, this patch looks much better. One final thing: Currently you have
> function called "search()" declared in the gncIDSearch.h header. This name
> is too generic and prone to clash with another function declaration
> anywhere else. Either you rename this into the same naming scheme as the
> others (so that it will be a unique enough name), or (more simply) you
> remove the declaration from the header file and solely declare it in the
> gncIDSearch.c file. Usually, people would probably go for the latter
> solution so that the implementation function isn't visible to the outside,
> in which case the naming also doesn't really matter.
> Regards,
> Christian
Another patch attached.  I did intend search() to be static, hence the simple 
function name, then forgot to make it so.  Thanks Christian.

Mike E

GPG Key: 1024D/050895C2
Search String: 0x050895C2
-------------- next part --------------
A non-text attachment was scrubbed...
Name: python_bindings_missing_vendor_search-03.patch
Type: text/x-patch
Size: 9485 bytes
Desc: not available
URL: <>

More information about the gnucash-devel mailing list