Request: require glib2 >= 2.12

Geert Janssens janssens-geert at
Fri Feb 19 17:24:23 EST 2010

I'd like to bump the minimum required glib2 for the 2.3.x series to 2.12. The 
reason is that I'm trying to solve a bug with database passwords that contain 
':' characters. This interferes with the code that uses ':' as separator for 
the database parameters.

My solution would be to encode the password in base64 before saving it and to 
decode it when required.

However, the base64 glib functions only appear in 2.12.

I think this bump shouldn't be any problem, because all distributions we care 
about have at least this version.
* The distro with the oldest glib version is (as always) RHEL5. It currently 
ships 2.12.3. Debian Lenny (the oldest non-EOLed-Debian) comes with 2.16.x. 
All others are more recent.
* The windows build uses 2.22
* Fink carries 2.20, MacPorts 2.22, I can't immediatly find what John uses for 
his MacOSX builds, but I'm pretty confident it's more recent than 2.12.

So in practise it won't affect any of the targeted platforms, yet allows
1. the use of the base64 functions
2. a cleanup of several HAVE_GLIB_2_{8,12} conditionals that are never 
triggered anyway.

As usual, the question: any objections ?


More information about the gnucash-devel mailing list