[Bug 609583] Postgresql backend loses data

Donald Allen donaldcallen at gmail.com
Sun Feb 21 12:22:59 EST 2010

On Sat, Feb 20, 2010 at 5:48 PM,  <z33b0b at gmail.com> wrote:
> A question for you folks --
> Does anyone know how far back a data file must go before the SQL interface
> starts truncating data?

This sort of implies that the cause of this problem is "how far back"
the data file goes. We don't know that-- we don't know what the cause
is, as yet.

 Is this bug specific to Donald's dataset, or has
> anyone else seen this?  I've got data just for 2009-10, and I'm not seeing
> any truncation or spurious amounts (so far, anyway).

It would seem that the problem I'm seeing is unusual. The work on the
database backend has been going on since 2009-05-15 and I have the
impression that it hasn't been ignored -- people are testing it. I
believe I'm the first one who has seen this, so there's certainly
*something* unusual about my data file. Having said that, I should
note my data file has never been written into by anything other than
Gnucash, though I do have some home-brew stuff that reads it for
report-generating purposes.


> Running Gnucash 2.3.7 built from svn r18386 on 2009-10-19, running on Ubuntu
> 9.04.
> Concernedly curious,
> -- Erik Anderson
> On Fri, Feb 19, 2010 at 8:53 PM, Donald Allen <donaldcallen at gmail.com>
> wrote:
>> Geert wrote:
>> Aside from the bug you are trying to analyse...
>> You can try to add a new account window (which is not the same as creating
>> a
>> new book), via menu View->New Accounts Page.
>> If this shows your existing account data, there is another bug in 2.3.10
>> regarding the accounts page not showing up automatically.
>> My response:
>> I tried View->New Accounts Page as you suggested and yes, the existing
>> account data shows up.  I then tried a 'Save As' and found that the
>> file dialog didn't include the new xml vs. database choice. This made
>> me realize that I'd built 2.3.10, forgetting to pass --enable-dbi to
>> configure. So I rebuilt it from scratch and now the issue with failing
>> to show at least the chart of accounts is gone -- it now works
>> correctly. So only the default configuration (without the database
>> support) exhibits the incorrect behavior. Doing a 'Save As'  sqlite3
>> and then restarting gnucash produces the same truncation behavior
>> described in bug 609583, which is not surprising, since I saw nothing
>> in the 2.3.9 or 2.3.10 release notes about this issue having been
>> fixed (I first observed it in 2.3.8).
>> BTW, I renamed Bug 609583 to "Database backend loses data", because
>> after I entered the bug, I did the same test with sqlite3 and observed
>> the same truncation behavior I saw with postgresql. So the issue
>> described in that bug appears to be above the database-specific code.
>> /Don
>> _______________________________________________
>> gnucash-devel mailing list
>> gnucash-devel at gnucash.org
>> https://lists.gnucash.org/mailman/listinfo/gnucash-devel

More information about the gnucash-devel mailing list