Unable to open sqlite3 files with 2.3.13 on Fedora 13.

Rick Rankin rick.rankin at yahoo.com
Mon Jun 7 19:51:37 EDT 2010

On 06/07/2010 12:58 PM, Geert Janssens wrote:
> On Monday 7 June 2010, Geert Janssens wrote:
>> On Monday 7 June 2010, Rick Rankin wrote:
>>>      ./configure --prefix=/tools/local --enable-dbi
>>> --with-dbi-dbd-dir=/usr/lib64/dbd
> Thinking more of this, you probably don't need to add the --with-dbi-dbd-dir
> option for configure anymore. I presume you are using this because previously
> GnuCash would default to /usr/lib/dbd even on 64-bit architectures. As of
> 2.3.13, GnuCash leaves it up to dbi to specify the default dbd directory,
> which should be properly set to /usr/lib64/dbd on 64-bit.
> So the easiest workaround is simply to build without --with-dbi-dbd-dir.
> Geert
>>> If I attempt to use the File
>>> -->  Open dialog with 2.3.13, the only format the appears in the "Data
>>>   Format:" selection list is "file". With 2.3.12, I see both "file" and
>>>   "postgres" as options.
>>> Has something in the build process changed to enable sqlite/postgres?
>> Thank you for reporting this. As Phill already replied, there is a change
>>   with respect to where dbi drivers are searched for when the
>>   --with-dbi-dbd-dir configure option is omitted.
>> It turns out the changes required for this contain a bug. I have just fixed
>>   it in r19234.
>> You can work around this bug by fixing your
>> /tools/local/etc/gnucash/environment file after you have run make install.
>>   The last line in that file defines GNC_DBD_DIR. Remove the double quotes
>>   around the definition. That should fix it.
>>> I was also having some issues with 2.3.12 on 32-bit Fedora-13. I was
>>> unable to open an sqlite3 file from an NFS share. IIRC, I got the same
>>> "Can't parse" message I quoted above. When I copied the file to the local
>>> hard drive, though, I could open the file and see all my transactions,
>>> but all the transaction amounts were zero.
>> What path do you use to access the file on nfs share ?


It's an automount path, but the result is the same if I use a regular 
NFS mount.

I've just verified that I still have problems with 2.3.13 on 32-bit 
Fedora 13; however, the problem doesn't manifest as I thought I 
recalled. When launched from a menu item, gnucash just appears to hang 
with the message "Loading user data...". When launched from the command 
line, I see the following error message:

libdbi: _error_handler:  (NULL conn/result handle)
*** glibc detected *** /tools/local/bin/gnucash: malloc(): smallbin 
double linked list corrupted: 0x08f4a058 ***

>> Regarding the zero amounts, do you get the same errors in
>>   /tmp/gnucash.trace as bug
>>   https://bugzilla.gnome.org/show_bug.cgi?id=611936 ?

I've also re-verified that I still get zeros when I copy the same file 
to the local disk. And yes, I see exactly the same error message as 
listed in the bug above.

>>>   I was getting ready to report those
>>>   errors to this list when I saw that 2.3.13 had been released. I thought
>>>   I'd try 2.3.13 before reporting anything against 2.3.12. Unfortunately,
>>>   I'm not able to get sqlite3 to work at all in either 32-bit or 64-bit
>>>   Fedora-13. Any suggestions would be appreciated.
>> Geert
>>> Thanks,
>>> --Rick
>>> _______________________________________________
>>> gnucash-devel mailing list
>>> gnucash-devel at gnucash.org
>>> https://lists.gnucash.org/mailman/listinfo/gnucash-devel
>> _______________________________________________
>> gnucash-devel mailing list
>> gnucash-devel at gnucash.org
>> https://lists.gnucash.org/mailman/listinfo/gnucash-devel

More information about the gnucash-devel mailing list