"No DBD drivers found" warning when running make check

Bill Hammond ka1ssr at gmail.com
Wed Feb 2 16:05:41 EST 2011

Hi Tommy!

On 01/31/2011 11:49 PM, Tommy Trussell wrote:
> On Mon, Jan 31, 2011 at 9:36 PM, Bill Hammond <ka1ssr at gmail.com> wrote:
>> Hello!
>> I am having trouble running make check on r20217.  Here's what's happening:
> ...
>> I'm running Ubuntu 10.10.  I checked and the dbd drivers have been
>> installed in /usr/lib/dbd.
> I just happened to check out and build r20217 this afternoon on this
> Ubuntu 10.04 box, and it worked fine.
> I did go through all the steps exactly as described at
> http://wiki.gnucash.org/wiki/Building#Ubuntu_10.04_LTS_.28Lucid_Lynx.29
> so if you used different ./configure parameters that might explain why
> mine worked and yours didn't... ?

I took the scorched earth approach by starting with a clean slate.  I
deleted my ~/development/gnucash installation and started at the
beginning of the procedure in the wiki.  I then checked out r20224,
executed the time honoured ./autogen.sh / ./configure
--prefix=/home/ka1ssr/unstable/gnucash --enable-debug --enable-doxygen
--enable-error-on-warning --enable-compile-warnings / make all install. 
Now I get this:


make[5]: Entering directory
/bin/bash ../../../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H
-I. -I../../.. -DG_LOG_DOMAIN=\"gnc.backend.dbi\"   -I.. -I../..
-I../../../src/backend -I../../../src/backend/sql -I../../../src/debug
-I../../../src/engine -I../../../src/app-utils -I../../../src/core-utils
-I../../../lib/libc -I../../../src/libqof/qof -pthread
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -DORBIT2=1
-pthread -I/usr/include/gconf/2 -I/usr/include/orbit-2.0
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include    -Werror
-Wdeclaration-after-statement -g  -g  -Wall -Wunused
-Wmissing-prototypes -Wmissing-declarations  -Wno-unused -MT
gnc-backend-dbi.lo -MD -MP -MF .deps/gnc-backend-dbi.Tpo -c -o
gnc-backend-dbi.lo gnc-backend-dbi.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I../../..
-DG_LOG_DOMAIN=\"gnc.backend.dbi\" -I.. -I../..
-I../../../src/backend -I../../../src/backend/sql -I../../../src/debug
-I../../../src/engine -I../../../src/app-utils -I../../../src/core-utils
-I../../../lib/libc -I../../../src/libqof/qof -pthread
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DORBIT2=1 -pthread
-I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -Werror -Wdeclaration-after-statement -g -g
-Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wno-unused
-MT gnc-backend-dbi.lo -MD -MP -MF .deps/gnc-backend-dbi.Tpo -c
gnc-backend-dbi.c  -fPIC -DPIC -o .libs/gnc-backend-dbi.o
mv -f .deps/gnc-backend-dbi.Tpo .deps/gnc-backend-dbi.Plo
make[5]: *** No rule to make target
`../../../src/app-utils/libgncmod-app-utils.la', needed by
`libgncmod-backend-dbi.la'.  Stop.
make[5]: Leaving directory
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/ka1ssr/development/gnucash/src/backend'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/ka1ssr/development/gnucash/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ka1ssr/development/gnucash'
make: *** [all] Error 2

Thanks for your help with this.


More information about the gnucash-devel mailing list