Lost input in quickfill cells due to race

Jim Paris jim at jtan.com
Mon Jul 18 18:12:04 EDT 2011

Christian Stimming wrote:
> in May you sent us a very useful patch to get rid of lost characters during 
> auto-completion ("quickfill") of text input in the account register window.
> However, subsequently I noticed a change in behaviour of the register auto-
> completion. Namely, during typing sometimes the cursor jumps to the end of the 
> selection where instead it previously stayed inside the selection, or more 
> precisely, when typing a quick-filled word character by character, the cursor 
> previously stayed right after the character that was just typed, but now it 
> occasionally jumps to the end of the selection. In effect, when typing 
> "Groceries", I type "G r o", but after the "G r" the cursor jumped to the end 
> of the selection and I end up with the word "Grocerieso", which is annoying.
> Reverting your patch from May (r20689) will make this behaviour go away again. 
> This is Ubuntu 10.10 with gtk-2.20.1. I don't want to revert your patch right 
> away as I'm sure you had some other bugs that went away by your patch, but 
> this particular other issue was introduced by it. (Unfortunately, it also went 
> into the stable 2.4.6 already, so it needs to be fixed there as well...)
> Do you have any ideas here?

Hi Christian,

I'm having a hard time reproducing it here.  I installed Ubuntu 10.10,
which comes with a different version of gtk:

  $ lsb_release -d
  Description:    Ubuntu 10.10
  $ pkg-config gtk+-2.0 --modversion
  $ gnucash --version
  GnuCash 2.4.7 development version
  Built 2011-07-18 from r3675a6f+

I typed "groceries" in a new register a couple dozen times, and had no
lost or misplaced characters.  I tried it both locally and x-forwarded.

Might it be triggered by some interaction with input methods?  I tried
using some, but it didn't seem to cause any problems.

Does it happen every time?  If not, how easy is it to reproduce?  This
change _should_ have gotten rid of any potential for race conditions,
but maybe there's something still there.  I don't see where that would
be happening, though.

(Herbert Thoma said it also happened on gtk-2.22.1, so I don't think
my newer gtk is the issue)


More information about the gnucash-devel mailing list