Increasing trunk libgtk dependency to 2.22.0?

Christian Stimming christian at
Fri Apr 13 16:32:30 EDT 2012

Am Freitag, 13. April 2012, 21:48:37 schrieb Christian Stimming:
> Currently, SVN trunk requires libgtk-2.18.1. However, recently (in r22086
> from patches in bug#672161) some new code was added that uses functions
> that were introduced in gtk-2.22, e.g. gtk_assistant_commit.
> Can we increase our required libgtk to 2.22? Current Ubuntu 11.10 comes with
> 2.24.6; other up-to-date distros probably with similar versions. What do
> you think?

Here's the most recent discussion for this issue:
and thread.

In that discussion and still today, the issue is that if we want SVN trunk to 
be compilable on RHEL6, we are stuck with at most gtk-2.18.9 [1], which in 
turn was released in March 2010. This would mean no major GUI code upgrades 
are possible with SVN trunk. A newer RHEL major release cannot be expected 
before summer this year, so maybe even later.

However, given that there isn't any current motion in gnucash to turn SVN 
trunk into a new stable series (2.5 and 2.6), I'd say we should drop RHEL6 
support of trunk and instead move to newer gtk versions here. This would at 
least enable all the preparation work for gtk3/gnome3 migration work, because, 
as discussed in the original thread, the gtk3 migration suggests to first move 
to gtk-2.24. I'd propose to do exactly this: Moving to gtk-2.24. 




More information about the gnucash-devel mailing list