jhbuild error on Mac OSX Lion

Reuben Cummings reubano at gmail.com
Wed Jan 11 08:14:06 EST 2012

>> One question though, the first time I ran
>> jhbuild bootstrap
>> and then I realized it should be
>> jhbuild bootstrap --skip=libiconv
>> Is it sufficient to just rerun it with the extra argument?
> Unfortunately, no. You have to uninstall libiconv, with
> jhbuild --moduleset=~/Source/jhbuild/modulesets/bootstrap.modules uninstall libiconv
> It should be enough, but if you get link errors at runtime you'll have to rebuild everything to get the rpaths right.
> My "clean Lion" (on a Dev Preview VM with no older stuff from earlier versions hanging around) build yesterday got to guile, which segfaulted during its install phase. I was focussing on getting the release done and didn't dig into it. Did your build get through that?
> Regards,
> John Ralls

guile built fine but I ran into the following problems

*** Checking out icon-naming-utils *** [55/68]
bunzip2 -dc "/Users/admin/gtk/source/pkgs/icon-naming-utils-0.8.90.tar.bz2"
| tar xf -
bunzip2: /Users/admin/gtk/source/pkgs/icon-naming-utils-0.8.90.tar.bz2
is not a bzip2 file.
*** Error during phase checkout of icon-naming-utils: could not unpack
tarball (expected icon-naming-utils-0.8.90 dir) *** [55/68]


checking for LIBSOUP... configure: error: Package requirements
(libsoup-2.4 >= 2.27.91) were not met:

No package 'libsoup-2.4' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBSOUP_CFLAGS
and LIBSOUP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error during phase configure of WebKit: ########## Error running
./configure --prefix /Users/admin/gnucash-stable --libdir
'/Users/admin/gnucash-stable/lib' --with-target=quartz --disable-video
--with-font-backend=pango   *** [60/68]


*** Checking out iso-codes *** [67/68]
bunzip2 -dc "/Users/admin/gtk/source/pkgs/iso-codes_3.28.orig.tar.bz2"
| tar xf -
bunzip2: /Users/admin/gtk/source/pkgs/iso-codes_3.28.orig.tar.bz2 is
not a bzip2 file.
jhbuild build: failed to unpack

More information about the gnucash-devel mailing list