Building gnucash on Ubuntu 12.04 Alpha

Colin Law clanlaw at
Tue Jan 24 09:29:40 EST 2012

On 24 January 2012 08:18, Colin Law <clanlaw at> wrote:
> On 23 January 2012 02:44, John Ralls <jralls at> wrote:
>> ...
>> Yes, that's normally what that message means. Try setting LD_LIBRARY_PATH=/usr/lib/libglade/2.0
>> and see if it at least gives you a different error.
> I tried setting LD_LIBRARY_PATH in the command line for the call of
> gnucash and the error did not appear, and the dialog came up to allow
> me to set the gconf path.  I did this and re-booted and now gnucash
> runs fine without needing to set the environment variable.
> Unfortunately I don't know whether a re-boot would have allowed it to
> run without the environment variable in the first place, or whether
> the fact that it ran once fixed the problem somehow, so I will have to
> go back to an earlier snapshot of my virtual machine and do it all
> again.  AAARHGH!  I am running virtualbox on a rather underpowered
> machine so that is rather tedious.

I was wrong, a reboot has not fixed it, I was confused, a not uncommon
occurrence.  The only way I can get it to run is by setting
On my working machine, which is Ubuntu 11.10 and has had gnucash
installed from the Ubuntu repository as well as manual builds, I do
not need to do this, and cannot work out how it manages to find the
library on that machine.  Any suggestions?  Otherwise I will just set
LD_LIBRARY_PATH and forget it.


More information about the gnucash-devel mailing list