Segmentation-Fault when click on File -> Open

John Ralls jralls at
Mon Dec 2 12:18:59 EST 2013

On Dec 2, 2013, at 8:47 AM, Herbert Mühlburger <mail at> wrote:

> Hash: SHA512
> Am 02.12.13 16:55, schrieb John Ralls:
>>> That's a very strange crash.
>>> I don't see it, but I'm got other weird behavior, where none of
>>> the GUI buttons, checkboxes, or GtkTreeList in the file chooser
>>> would respond, but only on the dmg downloaded from SF. Using the
>>> dmg on my local disk (the one I uploaded to SF yesterday) worked
>>> fine. I tried re-uploading that, same problem, so I regenerated
>>> the dmg and uploaded that. It now works, no problems with opening
>>> another account file. Please try downloading the new dmg. Just to
>>> be sure that there's no corruption, you can run md5 on the
>>> downloaded dmg (in Terminal); the hash should be
>>> b1a83ce89ba97439b3b24c2d60c20457.
>>> If you still have the problem, I need to know exactly what point
>>> you're getting the crash; from the stack trace you attached, it
>>> looks like it's after you select the file, either after
>>> double-clicking or clicking OK on the File Chooser dialog box.
> I'm afraid that it's not just a problem of the Mac OS X .dmg bundle
> ... I get the same error on Linux (Ubuntu) using the latest git
> commit. Attached you find my current gdb walkthrough as well as the
> stacktrace.

Please remember to CC the list on all replies: Use reply-list if your mail client provides it, otherwise use reply-all.

At this point I think you should open a bug report.

John Ralls

More information about the gnucash-devel mailing list