Current trunk doesn't work?

Christian Stimming christian at
Sat Dec 14 17:03:04 EST 2013

Am Samstag, 14. Dezember 2013, 13:53:26 schrieb John Ralls:
> On Dec 14, 2013, at 1:47 PM, Christian Stimming <christian at> 
> > I just updated to current trunk (r23561) and tried to enter my normal cash
> > transactions of the day, but it doesn't work (after pressing enter, the
> > txn is gone)? The trace has the message line
> > 
> >> * 22:46:49  CRIT <gnc.engine> xaccAccountGetCommoditySCU: assertion
> > `GNC_IS_ACCOUNT(acc)' failed
> > 
> > which is new. The message occurs right after hitting Enter in the new txn
> > line.
> > 
> > This is ubuntu 12.10 with guile-1.8.8 and swig-2.0.7. Can we please not
> > release this version until it is clear why this occurred and how this will
> > be avoided in the released version? Thanks!
> Yup. I discovered a major failure of import today when I tried to import my
> credit card accounts as well, and I’ve just started a bisect for that. Can
> you do a bisect on the transaction entry failure?

r23555 still works. 23556, 57, 58 don't compile with my guile-1.8.8 and 
swig-2.0.7. 23559 is the first version that compiles again, and no wonder, 
this is a version with failure (since there hasn't been any significant change 
since then).



More information about the gnucash-devel mailing list