crash when opening price database

Geert Janssens janssens-geert at
Fri Oct 25 16:36:54 EDT 2013

On Friday 25 October 2013 21:48:30 Herbert Thoma wrote:
> Hi,
> with latest HEAD I get a crash when I try to open the price database:
> * 21:35:55 OTHER <GLib-GIO> Settings schema
> 'org.gnucash.dialogs.edit-prices' is not installed Trace/Breakpoint
> ausgelöst
> I think I tried this about a week ago the last time, then it worked.
> There is no org.gnucash.dialogs.edit-prices in
> /opt/gnucash/test_install/cvs_head/share/glib-2.0/schemas/
> where I have GnuCash HEAD installed.
> find . -name "*.gschema.xml" in the source (I build in tree) directry
> does not show this either.
>   Herbert.
> _______________________________________________
> gnucash-devel mailing list
> gnucash-devel at

Hi Herbert,

Thanks for reporting this. I had pushed some cleanups in the settings. Unfortunately I mixed up 
a few schemas due to their very similar names: price-editor, edit-prices, prices,...

I have just pushed a commit to clean this up: there are two schemas left: pricedb-editor (for 
the prices overview window) and price-editor (for the dialog that shows the details for one 

Hopefully that fixes it.


More information about the gnucash-devel mailing list