make fails

GnuCash gnucash at
Sun Dec 28 00:36:14 EST 2014

Well, I learned a lot more than I ever thought trying to figure this out, but in the end I am embarrassed with the problem..  I was setting the prefix in my configure command, and while I did delete the source and start from scratch--the installation directory had files in it, not sure how as I never got to make install, but either way I was behind the keyboard, and the variety of errors came from head on collisions.  Changing the installation directory brought everything to normal..
Thanks, Bob

> On Dec 24, 2014, at 10:52 PM, John Ralls <jralls at> wrote:
>> On Dec 24, 2014, at 6:12 PM, GnuCash <gnucash at> wrote:
>> Not sure if this should be under the other emails, but I'm unable to get
>> this to work for the last little bit, the error is similar.  I've tried
>> to use "git clean -fdx"  and then even wiped it all and started again,
>> but still having the same error..
>> -------------------------------------
>> gnc-int128.hpp:229:41: error: 'UINT64_MAX' was not declared in this
>> scope
>> gnc-int128.hpp:229:53: error: 'UINT64_MAX' was not declared in this
>> scope
> C++11 is required for master. Either your compiler is too old and is lying to configure about its C++11 status or you have a defective stdint.h. Even if you manage to solve this problem it's likely that you'll have more as the C++ rewrite proceeds.
> We are deliberately pushing the envelope on compiler capability here in order to use the new language features; not all current stable distros are going to be able to build master, never mind even slightly obsolete ones. Sorry.
> Regards,
> John Ralls

More information about the gnucash-devel mailing list