building from svn
jralls at ceridwen.us
Fri Jan 24 14:35:17 EST 2014
On Jan 24, 2014, at 9:02 AM, Derek Atkins <warlord at MIT.EDU> wrote:
> alessandro basili <alessandro.basili at cern.ch> writes:
>> Hi there,
>> I'm having issues in building from source:
>>> configure: error: Library requirements (glib->2.0 >= 2.28 gio-2.0
>>>> = 2.25 gthread-2.0 gobject-2 gmodule-2) not met; consider
>>> adjusting the PKG_CONFIG_PATH environment variable if your
>>> libraries are in a nonstandard prefix so pkg-config can find them.
>> here's my apt-cache show for the gir1.0-glib-2.0 package which should
>> contain all of the required libraries:
> Umm.. what is "gir1.0-glib-2.0"? GnuCash needs "glib", not "gir".
It's the gobject introspection type library for GLib. He's apparently under the mistaken impression that it proves that he's installed the correct packages.
Alessandro, it doesn't demonstrate anything. In general you get that error because you have only the libraries installed and not the headers. Most distros, Debian included, separate the headers and package config files into a different package ending in -dev or -devel. You need those packages.
More information about the gnucash-devel