building master with boost

John Ralls jralls at
Sat Nov 1 16:26:04 EDT 2014

On Nov 1, 2014, at 11:42 AM, Carsten Rinke <carsten.rinke at> wrote:

> Hi,
> to check if some "front-porting" is working, I tried to compile on the master branch - for the first time.
> It told me that boost is missing:
> checking for boostlib >= 1.48.0... configure: We could not detect the boost libraries (version 1.48 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option.  If you are sure you have boost installed, then check your version number looking in <boost/version.hpp>. See for more documentation.
> configure: error: Boost 1.48.0 or later was not found and is required to build GnuCash
> So I downloaded Boost 1.56.0 into "/opt/lib/boost/boost_1_56_0".
> Running configure with an environment variable
> echo $BOOST_ROOT -> /opt/lib/boost/boost_1_56_0
> does not change anything.
> Running configure with
> --with-boost "/opt/lib/boost/boost_1_56_0"
> results in:
> checking build system type... Invalid configuration `/opt/lib/boost/boost_1_56_0': machine `/opt/lib/boost/boost_1_56_0' not recognized
> configure: error: /bin/bash ../config.sub /opt/lib/boost/boost_1_56_0 failed
> What can I do?


Study macros/m4_ax_boost_base.m4 to see what causes that error message and what configure is looking for, then make sure that you installed boost in a way that it finds it.

Did you build boost or just untar it in that directory?

John Ralls

More information about the gnucash-devel mailing list