[GNC-dev] Gnucash built from git doesn't start

Lothar Paltins lkpgcd at mailbox.org
Tue Oct 22 18:18:54 EDT 2019

Am 22.10.19 um 22:36 schrieb John Ralls:
> Everything has trouble finding modules in non-standard locations. Use LD_LIBRARY_PATH to add those non-standard locations to the search paths for ld and dlopen.

This doesn't seem to be an issue. The runtime paths in the binary are 
correctly set to /opt/gnucash/lib64 and /opt/gnucash/lib64/gnucash. 
Setting LD_LIBRARY_PATH doesn't help.

> BTW, cmake puts the global config files--the ones that normally live in <prefix>/etc--in some strange subdirectory of /etc when <prefix> starts with /opt. GnuCash doesn't know about that and won't be able to find gnucash/environment, which may or may not break things. It does other strange things if <prefix> is /usr or starts with /usr/local, so life is easier if you install in a directory under $HOME, which also saves you needing to sudo for make install.

The only strangely installed file I've found is 

As you've suggested, I've tried to install gnucash to $HOME/gnucash and 
now it works. Thanks for the hint.

But IMHO this is a bug of the make and install procedure. Gnucash should 
search for a file in the same location as it installed it.


More information about the gnucash-devel mailing list