r21668 - gnucash/trunk/src/test-core - [Testing] Provide list error handler, rename some functions

John Ralls jralls at code.gnucash.org
Sun Dec 4 19:06:28 EST 2011

Author: jralls
Date: 2011-12-04 19:06:28 -0500 (Sun, 04 Dec 2011)
New Revision: 21668
Trac: http://svn.gnucash.org/trac/changeset/21668

[Testing] Provide list error handler, rename some functions

Add an GTestFatalFunc which can examine a list of error conditions and suppress those messages and prevent their exiting while passing through any unexpected errors.

Rename test_silent_logger to test_null_handler and change it to a GTestFatalFunc (it can still be used as a GLogFunc).

Rename test_handle_faults to test_checked_handler and improve its flow and message display. It no longer asserts on a bad match.

More information about the gnucash-patches mailing list