gnucash master: Multiple changes pushed

Geert Janssens gjanssens at code.gnucash.org
Sun Mar 13 05:48:20 EDT 2016


Updated	 via  https://github.com/Gnucash/gnucash/commit/de8e2db3 (commit)
	 via  https://github.com/Gnucash/gnucash/commit/a4be710f (commit)
	 via  https://github.com/Gnucash/gnucash/commit/99d0b03e (commit)
	 via  https://github.com/Gnucash/gnucash/commit/b714df4c (commit)
	 via  https://github.com/Gnucash/gnucash/commit/80e20256 (commit)
	 via  https://github.com/Gnucash/gnucash/commit/213db2de (commit)
	 via  https://github.com/Gnucash/gnucash/commit/427d62e8 (commit)
	 via  https://github.com/Gnucash/gnucash/commit/f8090fa7 (commit)
	 via  https://github.com/Gnucash/gnucash/commit/4e2e45e8 (commit)
	 via  https://github.com/Gnucash/gnucash/commit/cc132ce9 (commit)
	 via  https://github.com/Gnucash/gnucash/commit/c709d502 (commit)
	 via  https://github.com/Gnucash/gnucash/commit/dae07fac (commit)
	 via  https://github.com/Gnucash/gnucash/commit/57a0b46b (commit)
	 via  https://github.com/Gnucash/gnucash/commit/82585bd8 (commit)
	 via  https://github.com/Gnucash/gnucash/commit/fd233545 (commit)
	from  https://github.com/Gnucash/gnucash/commit/71f7f457 (commit)



commit de8e2db3b2b33b63fedde057b3b7d4edf11b4c8a
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Fri Mar 11 09:25:26 2016 +0000

    Change look_for_old_mapping to return NULL
    
    look_for_old_mapping should return NULL when we find an existing
    map_account

commit a4be710fdd185fd56f19cfebbab5b9bcff2eee21
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Thu Mar 10 17:27:57 2016 +0000

    Rename some function to better reflect there use
    
    Change some function names to better reflect there use and change
    look_for_old_mapping to return map_account and use this to see if we
    need to convert entry

commit 99d0b03e0f38a151ac02cc6c273ddf6bb7771d62
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Thu Mar 10 17:16:05 2016 +0000

    Remove unnecessary use of g_strdup of full_name
    
    Remove the unnecessary use of g_strdup on full_name and access it
    directly

commit b714df4c8c1458b17b488bfaeab31b89e10477a2
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Sun Mar 13 10:04:03 2016 +0100

    Change some functions to reduce code duplication
    and move feature setting to where KVP is actually
    set

commit 80e20256ad811dd1e3528c32c2acc9d52c42433a
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Sun Mar 13 09:46:13 2016 +0100

    Add feature flag to prevent versions older than 2.6.12 from opening the data file.

commit 213db2de52b4078255bb8921a2be3951be45c2f8
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Mon Mar 7 17:09:35 2016 +0000

    Use GncImapInfo instead of struct imap_info where
    it makes sense to.

commit 427d62e805b25b9165731127490d5498dfb495c4
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Mon Mar 7 13:34:07 2016 +0000

    Change when an existing entry exists we add it to
    the converted entry

commit f8090fa78e68804d711aed4d353d210b0cef1531
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Mon Mar 7 12:32:26 2016 +0000

    Improve old separator recognition by looking for
    the longest top level entry that matches the
    prefix. Also test for valid map account so we are
    not wasting time trying to convert a valid
    full_name.

commit 4e2e45e87133445df44091f458766cc9349d210a
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Mon Feb 29 12:51:40 2016 +0000

    Modify gnc_account_imap_convert_bayes to run only
    once by setting a KVP Book entry and then testing

commit cc132ce947cd02a6e3aabe0568229c4db79f5985
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Mon Feb 29 12:49:58 2016 +0000

    Add Bayesian conversion to end of file open

commit c709d5024680c6499b4d5248939237c72aa5fd28
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Mon Feb 29 09:46:37 2016 +0000

    Check for existing guid entries and update

commit dae07facf069ca601c6fe4be88b283eb86212736
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Mon Feb 29 09:45:29 2016 +0000

    Create function to change Bayesian entries based
    on full account name to that of the account guid

commit 57a0b46b41b5023702ba9d9e23217e505f7b29cc
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Mon Feb 29 09:44:10 2016 +0000

    Modify Imap helper function to find map account by
     guid

commit 82585bd8c4be2176f963e86a3b5161428e1e7547
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Mon Feb 29 09:43:16 2016 +0000

    Rename account_name to account_guid to reflect
    change of use and remove newlines from PINFO lines

commit fd2335452832230ba436c6a62d99e21418579ca0
Author: Robert Fewell <14uBobIT at gmail.com>
Date:   Mon Feb 29 09:41:45 2016 +0000

    Change Bayes functions to use guid account string
    instead of full account name in kvp path



Summary of changes:
 src/engine/Account.c           | 368 ++++++++++++++++++++++++++++++++++-------
 src/engine/Account.h           |   9 +-
 src/gnome-utils/gnc-file.c     |   5 +
 src/gnome/dialog-imap-editor.c |   8 +-
 4 files changed, 327 insertions(+), 63 deletions(-)



More information about the gnucash-patches mailing list