gnucash: New Branch '2.7.3'

John Ralls jralls at code.gnucash.org
Sat Dec 30 20:17:56 EST 2017


        at  https://github.com/Gnucash/gnucash/tree/4cb658776922c5be2d1446cc89535b2bc2c89a6e (tag)
   tagging  ac05578ba5e7d716e367c6952f1d681f590ea3b7 (commit)
  replaces  2.7.2
 tagged by  John Ralls
        on  Sat Dec 30 16:00:39 2017 -0800


Release GnuCash 2.7.3

Christopher Lam (70):
      Bugzilla 790526 Correct weeknum calculator
      options.scm: upgrade lookup-value to learn section changes
      OBSOLETE: 'exact-time removed
      BUGFIX: change date-sorting-types
      ENH: Move Transaction Matcher to new Filter tab
      ***reindent and remove trailing whitespace***
      REFACTOR: rename funcs, centralize strings
      REFACTOR: Delete unused functions
      ENH: Move Account matcher to Filter tab
      ENH: add reconciled status filtering
      ENH: Optimise Transaction Matcher filter
      REFACTOR: always run qof-query-destroyer
      REFACTOR: move some funcs to refactor later
      REFACTOR: combine 2 key-choice-list into 1
      REFACTOR: centralize numerous used-* into column-uses? helper function
      REFACTOR: centralize sortkey-list
      REFACTOR: centralize date-subtotal-list
      REFACTOR: centralize key-choice-list
      REFACTOR: centralize DATE-SORTING-TYPES and SUBTOTAL-ENABLED
      REFACTOR: centralize BOOK-SPLIT-ACTION
      REFACTOR: improve heading-list to handle dual headings
      REFACTOR: simplify functions, reduce arguments
      REFACTOR: move *-choice-list into options-generator
      REFACTOR: move add-split-row into make-split-table
      ENH: Show account description in subheadings
      REFACTOR: rewrite renderers to lookup 'renderer-key from sortlists
      REFACTOR: initialize accounts/filter by to null list
      COSMETIC:Rename subtitles -> subheadings in sorting/account display
      REFACTOR: Simplify Trans Number handling
      REFACTOR: use scheme idioms
      REFACTOR: simplify do-rows-with-subtotals to use fewer args
      ENH: add custom sorter which can handle periodic dates
      ENH: show original currency, and enable multicolumns.
      ENH: "Price" column gets number-cell styling.
      ENH: "Shares" column gets number-cell styling
      ENH: Enable sign reversal for amount 'single only
      COSMETIC: Move Display>Sign reversal option
      REFACTOR: Use time64 instead of timepair
      ENH: dual columns subtotals now in correct column
      ENH: disable filter accounts selector if filter-mode=none
      REFACTOR: Centralize options
      ENH: add infobox to summarise options used
      REFACTOR:Centralise sign-reverse-list
      REFACTOR:Move Void-status filter to filter tab
      REFACTOR: move column-uses? location
      REFACTOR+ENH:Add common-currency mnemonic to header if enabled
      ENH: 'original currency amt' now shows dual columns
      REFACTOR: move calculated-cells to allow access from add-subtotal-row
      ENH: Upgrade Sign Reversal to use global preference by default
      BUGFIX: Fix incorrect N_ and _ handling
      BUGFIX: Reverse sign on display only
      REFACTOR: start refactor subtotal
      REFACTOR:bisect subtotal-get-info into primary/secondary
      REFACTOR: simplify do-rows-with-subtotals
      REFACTOR: simplify render-summary
      ENH: if no Display/* selected, insert empty left-column
      REFACTOR: centralize left-cols to a vector-list
      REFACTOR: simplify num/t-num display code
      REFACTOR: remove 'renderer-key lookup symbol, simplify custom sorter
      COSMETIC: if grand-totals=#f then omit <hr>
      ENH: Add option to choose infobox display summary
      ENH: Add debit/credit friendly names in subheading rendering
      ENH: Add sortkey Reconciled Status
      ENH: Add indenting for main data and subheadings/subtotals
      ENH: Formalise Reconciliation Report as a new menu item.
      ENH: Add 'daily subtotal strategy
      ENH: Optionally hide transactions
      REFACTOR: gnc-numeric not available in scheme anymore
      COSMETIC: amend strings in options
      ENH: display infobox when no accounts matched

Geert Janssens (24):
      Fix installation destinations for overrides and quotes scripts
      Handle the splash/lock file warning more the gtk way
      Ensure the main window is mapped before any reminder dialogs are shown at startup
      Improve window management
      Alter function signature of gnc_(verify|yes_no|info|warning|error)_dialog
      Set transient parents for all query views and dialogs
      Fix transient parent for SX since last run... at startup
      Fix missing transient parent warnings for several business dialogs
      Add transient parent for search dialog
      Fix transient parent warnings in search callbacks
      Fix transient parent warnings for tip-of-the-day and file dialogs
      Add infrastructure to handle preference schema migrations and use it to replace one preference
      Add support for guile 2.2
      Drop guile 1.8 support
      Add unit test for rewritten scheme error handlers
      Force build order on report system support files
      Replace GNC_CONFIGURE(2) with configure_file
      Remove cmake hoop to change file permissions
      Merge branch 'fix_bayes' of https://github.com/limitedAtonement/gnucash into unstable
      Merge branch 'prices-in' of https://github.com/Bob-IT/gnucash into unstable
      Fix a few compile warnings-turned-errors
      Update POTEFILES.in
      Merge branch 'unstable-TR-plus' of https://github.com/christopherlam/gnucash into unstable
      A few translatable string changes in the warnings for editing reconciled splits

Guy Taylor (4):
      Fix Python GncNumeric for non (int, int) pairs
      Add GncNumeric to native Python Fraction
      Use glib.h over custom typedefs in Python SWIG
      Use builtin SWIG conversions for glib types

John Ralls (64):
      Remove common/test-core/unittest_support.py from git.
      Fix python tests in tarball builds.
      Use GNUInstallDirs in CMake Builds
      Merge Aaron Laws's 'unneeded-build-flag' into unstable
      Fix null pointer dereference segfault.
      Merge branch 'PyGncNumeric' into unstable
      Fix python test failure on Travis.
      Remove unset variable SWIG_ARGS from Makefile.am
      Add GLIB_CFLAGS and srcdir to SWIG includes.
      Fix path to compiled guile files in environment.in.
      Fix the fixed path to compiled guile files.
      More GNUInstallDirs path fixes.
      Remove overrides directory as being obsolete.
      Fix autotools build after removing gnucash/overrides.
      Some fixes to complete removing gnucash/overrides.
      Remove gnucash/test.
      LIBDIR is not lib--two more CMakeLists.txt.
      One more stray header in libexec.
      Rework directory determination in CMake builds.
      Test more thoroughly gnc-timezone's parsing of the zoneinfo database.
      Bug 791422 - gnucash 2.7 no longer opens sqlite3...
      Fix the Mac install_name_dir to point at CMAKE_INSTALL_FULL_LIBDIR.
      Fix offset handling in GncDateTime struct tm ctor, gnc_mktime, & gnc_timegm.
      Remove (unused because of an error) parse-to-tm string timespec construction.
      Fix posted-date scrub incrementing the day in central pacific timezones.
      Fix neutral time for consistent dates in mid-pacific time zones.
      Revert post-construction adjustment of ldt for DST.
      Handle mid-pacific timezones in date-sensitive tests.
      Add minimum version to feature and fix copy-paste error in test-flat-bayes.
      Add test-flat-bayes to autotools build.
      Merge Rob Gowin's Partial Fix for Bug 787497 into maint.
      Update Dutch and Serbian translations from the Translation project.
      Fix python tests when building from tarball.
      Release 2.6.19
      Merge branch 'maint' into unstable
      Fix timezone constructor crash when zone file has no transitions.
      Add tests for GMT and GMT+7 timezones.
      Fix date offset error in datetime test.
      Fix duplicate test-case name.
      Add test-date-utilities to CMakeLists.txt and Makefile.am.
      Merge Chris Lam's Bug 790526 fix into maint.
      Remove SIGFIG rounding from price calculation.
      Replace the gnc:numeric pair with normal Scheme rationals.
      Don't build borrowed/gwengui-gtk3 if its provided by gwenhywfar.
      Fix use of guile function introduced in 2.0.10, not available in Ubuntu14.04.
      Enable reading undelimited YYYYMMDDHHMMSS time strings.
      Bug 791848 - GC 2.6.x does not handle ISO dates introduced with GC 2.7
      Fix picky gcc-7.2 complaint about a %d conversion not fitting in 3 bytes.
      Fix autotools test setup for test-date-utilities.
      Test struct tm* returns from gnc_gmtime and gnc_localtime
      Enforce -Werror on C++ files and fix resulting errors.
      Bug 791848 - GC 2.6.x does not handle ISO dates introduced with GC 2.7.
      Fix CXX Flags for g++.
      Another attempt to make Travis's g++ happy about compiler warnings.
      Fix Travis 'dangling else' warning.
      Merge Bob Fewell's 'gtk3-update11' into unstable.
      Fix crash in customer/employee/vendor reports.
      Bug 616709 - Pressing delete key while editing account name offers...
      Merge branch 'maint' into unstable
      Fix -Wsign-compare error.
      Fix distcheck errors.
      Prevent "Save before closing" dialog from appearing at startup.
      Merge Bob Fewell's 'gtk3-update12' into unstable.
      Release GnuCash 2.7.3

Rob Gowin (3):
      Handle cases where LIBDIR is not "lib"
      Handle cases where LIBDIR is not "lib"
      Partial fix for Bug 787497 - Disabling options cripples dist package

Robert Fewell (75):
      Add property files for the csv price importer
      Add price import files for the csv price importer
      Rename function gnc_csv_price_col_type_strs to gnc_price_col_type_strs
      Add CSV Price importer assistant files
      Remove not required account update
      Some text changes
      Add option to specify Commodity from and Currency to for whole file
      Made changes to preset column types to align with other changes
      Remove duplicated function
      Fix some errors in conversion of some function names
      Change the settings file to save and load price settings.
      Minor changes and tidy up
      Change the way commodity and currency combo's are shown.
      Various changes to comments in source files and displayed text.
      Add a test for from_commodity not being the same as to_currency
      Add the ability to test from_commodity and to_currency being the same.
      Reorder the create price procedure.
      Rename gnc-csv-trans-settings.* to gnc-csv-import-settings.*
      Pot file changes for new files and settings rename
      Make changes for Gtk3 compatibility
      Replace date parse function with one from gnc_datetime
      Add a test for empty values
      Add property files for the csv price importer
      Add price import files for the csv price importer
      Rename function gnc_csv_price_col_type_strs to gnc_price_col_type_strs
      Add CSV Price importer assistant files
      Remove not required account update
      Some text changes
      Add option to specify Commodity from and Currency to for whole file
      Made changes to preset column types to align with other changes
      Remove duplicated function
      Fix some errors in conversion of some function names
      Change the settings file to save and load price settings.
      Minor changes and tidy up
      Change the way commodity and currency combo's are shown.
      Various changes to comments in source files and displayed text.
      Add a test for from_commodity not being the same as to_currency
      Add the ability to test from_commodity and to_currency being the same.
      Reorder the create price procedure.
      Rename gnc-csv-trans-settings.* to gnc-csv-import-settings.*
      Pot file changes for new files and settings rename
      Make changes for Gtk3 compatibility
      Replace date parse function with one from gnc_datetime
      Add a test for empty values
      Merge branch 'prices-in' of /mygit/gnucash into prices-in
      Replace magic numbers used in std::get... with values from enum
      Update file with changes for transient dialog changes
      Remove surplus statement
      Change the way the import settings are handled
      Change the relative path to a full one for rpath
      Make sure the tree view has focus on Account tree page load
      Prevent the tab being the focus
      Make sure the sheet has focus in a register when opened
      Make sure the sx tree view has focus on page load
      Replace tabs with spaces in a couple of source files
      Make sure the webkit widget has focus on report load
      Change tabs to spaces in gnc-html-webkit2.c
      ake sure the Account tree view has focus when budgets open
      Replace tabs with spaces for budget files
      Make sure the tree view is the focus on an owner page
      Add function to get whether sheet is read only
      Set focus for invoice pages
      Bug 616709 - Stop the delete button on the Account page
      Bug 771667 - Change reconciled splits warning
      Fix register cell height by adding 1px for cell border
      Add a left margin to report zoom to align with other options
      Fix Transient parent warnings for SX editor
      Fix Critical errors when SX editor loaded
      Fix Test for filepath is NULL when cancel pressed for export
      Fix Invalid cast from GncWebkitHtml to GtkWindow
      Fix transient parent warnings for budgets
      Fix error when sheet is read only.
      Fix There is no budget icon yet so set it to the account one.
      Fix some transient parent warnings
      Fix register move to another window

christopherlam (5):
      Fix -DWITH_SQL=OFF Build.
      add unittest for bugzilla 790526
      typo
      fix unit test again
      fix silly mistake

lmat (23):
      Removing unneeded build flag from docker
      Removing Arch Linux Autotools build
      GUID/Flat bayes handling in 2.6
      Account.c to Account.cpp
      kvp frame to template and correcting failure macro
      Change kvp string representation
      Implement flat bayes kvp
      Fixed conversion problem
      Removed qof_instance_set_kvp, qof_instance_get_kvp
      Added test for and corrected get_bayes_info
      Kvp no longer parses entries looking for delimiters
      Renaming functions to get rid of temporary name
      Corrected memory management issue
      Keep tokens as they are, don't translate them
      Correct kvp to_string typo
      kvp string: allocate enough space
      Remove unused kvp function
      Changed some constants to constexpr
      Code review responses
      Changed bayes import map design
      Rename qofinstance function
      Correct string cache code
      Adding to version info to feature string





More information about the gnucash-patches mailing list