gnucash master: Multiple changes pushed

John Ralls jralls at code.gnucash.org
Thu Jun 4 17:11:02 EDT 2020


Updated	 via  https://github.com/Gnucash/gnucash/commit/b8d514e1 (commit)
	 via  https://github.com/Gnucash/gnucash/commit/6a1cb5ee (commit)
	 via  https://github.com/Gnucash/gnucash/commit/c73a1bd4 (commit)
	 via  https://github.com/Gnucash/gnucash/commit/a320035f (commit)
	 via  https://github.com/Gnucash/gnucash/commit/65e2639d (commit)
	from  https://github.com/Gnucash/gnucash/commit/0281ef2f (commit)



commit b8d514e157fb7bbd1e175b19eb13a3bca0921788
Author: John Ralls <jralls at ceridwen.us>
Date:   Thu Jun 4 14:07:20 2020 -0700

    Don't try to unlock the GncDbiSqlConnection when it was connected read-only.
    
    If it's locked it's not *our* lock.

commit 6a1cb5eecd794d65ab0d15161b1628750b29acb6
Author: John Ralls <jralls at ceridwen.us>
Date:   Thu Jun 4 13:05:55 2020 -0700

    Replace the three bool parameters to qof_session_begin to an enum.
    
    For clarity. In so doing found the backend behavior a bit inconsistent
    so it's modified to do what the enum values indicate.
    
    In the course of changing the various calls I found some implementation
    errors in the back end and corrected them.

commit c73a1bd4751687a18fb5a35fc63f9943a66cf580
Author: John Ralls <jralls at ceridwen.us>
Date:   Thu Jun 4 11:00:52 2020 -0700

    Extract function template drop_database.

commit a320035f42f556bd1ce8961c5d8fd11ce985769a
Author: John Ralls <jralls at ceridwen.us>
Date:   Tue Jun 2 11:48:33 2020 -0700

    QofSession, QofBackend: Change book_id to uri.
    
    It's more descriptive and less likely to be confused with the book:id value
    in XML files that is the book's GUID.
    Also changed the QofSessionImpl::begin new_uri parameter from std::string to
    const char*. There's no point in allocating a string just to call
    new_uri.c_str() all over the place.

commit 65e2639de4129d699ea4ad614c8e01da10295b3e
Author: John Ralls <jralls at ceridwen.us>
Date:   Tue Jun 2 10:54:09 2020 -0700

    Delete QOF_STDOUT.
    
    Apparently a hack for the long-gone QSF backend.



Summary of changes:
 bindings/python/sqlite3test.c                      |   2 +-
 gnucash/gnome-utils/assistant-xml-encoding.c       |   2 +-
 gnucash/gnome-utils/gnc-file.c                     |  25 ++---
 gnucash/gnome-utils/gnc-main-window.c              |  22 ++---
 gnucash/gnucash-commands.cpp                       |   4 +-
 gnucash/import-export/aqb/test/test-kvp.c          |   4 +-
 libgnucash/backend/dbi/gnc-backend-dbi.cpp         | 104 +++++++++++----------
 libgnucash/backend/dbi/gnc-backend-dbi.hpp         |   2 +-
 libgnucash/backend/dbi/gnc-dbisqlconnection.cpp    |  15 +--
 libgnucash/backend/dbi/gnc-dbisqlconnection.hpp    |   5 +-
 .../backend/dbi/test/test-backend-dbi-basic.cpp    |  22 ++---
 .../backend/sql/test/utest-gnc-backend-sql.cpp     |   2 +-
 libgnucash/backend/xml/gnc-backend-xml.cpp         |   5 -
 libgnucash/backend/xml/gnc-xml-backend.cpp         |  46 ++++-----
 libgnucash/backend/xml/gnc-xml-backend.hpp         |   4 +-
 libgnucash/backend/xml/test/test-load-xml2.cpp     |   3 +-
 libgnucash/backend/xml/test/test-save-in-lang.cpp  |   4 +-
 libgnucash/engine/qof-backend.hpp                  |  23 +----
 libgnucash/engine/qofsession.cpp                   |  88 +++++++++--------
 libgnucash/engine/qofsession.h                     |  96 ++++++++++---------
 libgnucash/engine/qofsession.hpp                   |  14 +--
 libgnucash/engine/test/test-qofinstance.cpp        |   4 +-
 libgnucash/engine/test/test-qofsession-old.cpp     |  60 ++++++------
 libgnucash/engine/test/test-qofsession.cpp         |  24 ++---
 libgnucash/engine/test/utest-Transaction.cpp       |   2 +-
 25 files changed, 280 insertions(+), 302 deletions(-)



More information about the gnucash-patches mailing list