Problem compiling gnucash 1.6.6

Jacob Lambrecht
11 Aug 2002 08:18:38 -0600

On Sat, 2002-08-10 at 23:01, David Hampton wrote:
> On Sat, 2002-08-10 at 21:16, Jacob Lambrecht wrote:
> > I grabbed the latest g-wrap
> > (version 1.3.2) and it installed fine with prefix=/usr. I tried to run
> > make again for gnucash but I got the same error. Can anyone help me with
> > this please? 
> Gnucash 1.6.6 requires g-wrap 1.2.1.
> David

That worked great. Everything compiled fine but when I went to run
gnucash I got this error:

ERROR: In procedure scm-error in expression (scm-error (quote
misc-error) #f ...):
ERROR: Loaded gnucash srfi-8.scm in unknown Guile version:1.4.1.
If you're running a Guile newer than 1.4, then this file should
not have been installed.  Please report the bug.

I checked file srfi-8.scm and I just changed this line:

(string=? "1.4" (version)))
(string=? "1.4.1" (version)))

BTW: I am running: guile-config - Guile version 1.4.1

Once I changed that gnucash loaded up and is now running fine.