Gnucash 1.6.6 on RedHat 7.3 only starts as root

Daniel Brahneborg
Sat, 31 Aug 2002 00:19:48 +0200

On Fri, Aug 30, 2002 at 04:03:51PM -0600, Peter T. Abplanalp wrote:
> > On Fri, Aug 30, 2002 at 03:29:34PM -0600, Peter T. Abplanalp wrote:
> > > On Fri, Aug 30, 2002 at 11:15:05PM +0200, Daniel Brahneborg wrote:
> > > > I started using gnucash a few weeks ago, and it has worked pretty fine.
> > > > One day I made the mistake of starting it as root, and since then it
> > > > absolutely refuses to run when I'm my usual user.  It complains about
> > > > not being able to get the lock for the data file, and then it just
> > > > stops.  When running it with --loglevel 6 the output ended with the two
> > > 
> > > in the same directory as your data file, you will find a file with the
> > > extension .LCK.  it is probably owned by root and thus unmodifiable by
> > > a mere user.  remove it as root and try again to start gnucash as your
> > > normal id.
> > 
> > Removing it indeed gets rid of the "can't lock the database" warning,
> > but after reading the data file it still blocks.  I get the first splash
> > screen, and some rather small (200 x 40 pixels, circa) window after a
> > few seconds, but after that it just sist there doing nothing.  The
> > process is still active, but the screen is empty.
> your data file is probably also owned by root.  in the directory where
> you keep your datafile execute the following as root: chown <user> *
> then try again.

Done that, but it makes no difference.

> the reason you get a blank screen is that (this is a theory) if
> gnucash can't open or can't find the data file it last used, it starts
> with no data file.  you can then go to the file menu and pick open
> file, surf to your datafile and open it.  subsequently it should work.

Well... That would be easier if I actually had a window with a file
menu, but I don't get that either.  ;)

I get absolutely nothing.  No window, no dialogs, no error messages on
the console, no nothing.  If the files are owned by root I get a dialog
where it complains about not being able to lock the database, but when I
close that dialog, I get nothing more.

It's as if has tried to read a window definition file of some sort,
found nothing (or wasn't able to read it, or something), but forgot to
check this and just assumed that something would get shown.  This is
just speculation on my part though.