Slackware user trying to get gnucash compiled

Jeremy Gregorio gunvalk at
Sun May 9 01:01:19 EDT 2004

Hi all, I've been trying to get gnucash complied for some time now (the 
packages I've found online want guppi, and I can't get that compiled either 
nor find a guppi package). Right now I can do the './configure --prefix=/usr 
--disable-guppi' just fine, but I bomb out on the compile. I've tried 
installing glade-2.0.1 from source. First time I tried to compile it couldn't 
find glade.h, so I make a /usr/include/glade directory and dumped all the 
header files from glade-2.0.1/glade/ in there. Right now it looks to me like 
it's looking for GladeXML (I've got the Guppi .40 source and it gives me  
"`GladeXML' undeclared (first use in this function)" among other errors 
compiling). Is this something part of Glade that I somehow managed to not 
compile in? Or is this a version conflict? I've stopped short of installing 
gtk+-1.2 from source, but other than that I don't know what else to try. 
Anyway, here's the output from when things bomb out:

gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src/gnc-module -I../../src/engine 
-I../../src/network-utils -I../../src/app-utils -I../../src 
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/include/gnome-1.0 
-I/usr/include/freetype2 -DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include 
-I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include 
-I/usr/X11R6/include -I/usr/include/gdk-pixbuf-1.0 -I/usr/include/gnome-xml 
-I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include 
-I/usr/X11R6/include -I/usr/include/gnome-1.0 -DNEED_GNOMESUPPORT_H 
-I/usr/lib/gnome-libs/include -I/usr/include/orbit-1.0 -I /usr/include/g-wrap 
-g -O2 -Wall -Wunused -Werror -c QuickFill.c   -fPIC -o .libs/QuickFill.o
In file included from QuickFill.c:36:
dialog-utils.h:165: syntax error before '*' token
cc1: warnings being treated as errors
dialog-utils.h:165: warning: type defaults to `int' in declaration of 
dialog-utils.h:165: warning: data definition has no type or storage class
make[4]: *** [QuickFill.lo] Error 1
make[4]: Leaving directory 
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory 
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/jeremy/software/gnucash-1.8.9/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/jeremy/software/gnucash-1.8.9'
make: *** [all-recursive-am] Error 2

Thanks again. 

Jeremy Gregorio

More information about the gnucash-user mailing list